summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libnotify
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libnotify')
-rw-r--r--x11-libs/libnotify/Manifest1
-rw-r--r--x11-libs/libnotify/libnotify-0.7.6-r1.ebuild68
-rw-r--r--x11-libs/libnotify/metadata.xml5
3 files changed, 74 insertions, 0 deletions
diff --git a/x11-libs/libnotify/Manifest b/x11-libs/libnotify/Manifest
new file mode 100644
index 000000000000..2f6b157a9631
--- /dev/null
+++ b/x11-libs/libnotify/Manifest
@@ -0,0 +1 @@
+DIST libnotify-0.7.6.tar.xz 280388 SHA256 0ef61ca400d30e28217979bfa0e73a7406b19c32dd76150654ec5b2bdf47d837 SHA512 5d656ee7ee5caeb95aec4adb973795dc72fc620cd36b9fe3d4f910951945bd5df70ee1c422cd6aca9c38a9ba2760562e479fc8fb9269449924a5b24d762d03df WHIRLPOOL e619c8d10790f5b78730a2599c407bc951de68b189f460c72999776eaf92014aded0953ca06398cce7ad09fd8c87e1c7727cea4f4c81eccee0a8b2f2bafd195b
diff --git a/x11-libs/libnotify/libnotify-0.7.6-r1.ebuild b/x11-libs/libnotify/libnotify-0.7.6-r1.ebuild
new file mode 100644
index 000000000000..7e515e7235f9
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.7.6-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils gnome.org multilib-minimal
+
+DESCRIPTION="A library for sending desktop notifications"
+HOMEPAGE="http://git.gnome.org/browse/libnotify"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="+introspection test"
+
+COMMON_DEPEND="app-eselect/eselect-notify-send
+ >=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.32 )"
+RDEPEND="${COMMON_DEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r4
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/gobject-introspection-common-1.32
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+ test? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )"
+PDEPEND="virtual/notification-daemon"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+src_prepare() {
+ sed -i -e 's:noinst_PROG:check_PROG:' tests/Makefile.am || die
+
+ if ! use test; then
+ sed -i -e '/PKG_CHECK_MODULES(TESTS/d' configure.ac || die
+ fi
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf \
+ --disable-static \
+ $(multilib_native_use_enable introspection)
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/reference/html docs/reference/html || die
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+
+ mv "${ED}"/usr/bin/{,libnotify-}notify-send #379941
+}
+
+pkg_postinst() {
+ eselect notify-send update ifunset
+}
+
+pkg_postrm() {
+ eselect notify-send update ifunset
+}
diff --git a/x11-libs/libnotify/metadata.xml b/x11-libs/libnotify/metadata.xml
new file mode 100644
index 000000000000..2953eb8e0471
--- /dev/null
+++ b/x11-libs/libnotify/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>freedesktop</herd>
+</pkgmetadata>