summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/tslib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/tslib')
-rw-r--r--x11-libs/tslib/Manifest2
-rw-r--r--x11-libs/tslib/metadata.xml8
-rw-r--r--x11-libs/tslib/tslib-1.0-r3.ebuild40
3 files changed, 50 insertions, 0 deletions
diff --git a/x11-libs/tslib/Manifest b/x11-libs/tslib/Manifest
new file mode 100644
index 000000000000..6ddc27b99a1b
--- /dev/null
+++ b/x11-libs/tslib/Manifest
@@ -0,0 +1,2 @@
+DIST tslib-1.0-patches-5.tar.bz2 6602 SHA256 5b4f4183de0bcc9ceb09565d55a2f6f08f3befc0962af423f9a4fd809d36db2f SHA512 dcde900942a3c9e9114e2c36d1d9554eeae8e5ca64463d69c52188a30734b19d6ba0439e8bb009b0d535dfae3f8f8e688a6861ec0a0371fdcb0e9986abb963de WHIRLPOOL fe14ce85a6f5f92e7c919fefcfc6cd303ede10d45670b150bc7baa3db99f64bb6d55f05416a3a8545cca205513fd80a0ebbe76c1ef8715e32235b91780e1374c
+DIST tslib-1.0.tar.bz2 47522 SHA256 9c40d914e4f6fe00bdd77137d671c7ce4f211686228f2eb8b2d3c2360bc249c8 SHA512 a12e569b1d9cd809776a605775c3000f4e405789d95eeda21451d3911b5aa67003c921d9988f5ea8eba8b32108c8b0816e6609b5f013a2594d27b6e00e75de8c WHIRLPOOL 176346c7d5ac9fb36c25bfc3b98699c26acd642ab4621c0a8e5b01999a9451e0ad7f3a87c8268b7c82b326fc6f1867fb2a132810c2a17aa417a245b2efbd3ec3
diff --git a/x11-libs/tslib/metadata.xml b/x11-libs/tslib/metadata.xml
new file mode 100644
index 000000000000..0288e627e3ff
--- /dev/null
+++ b/x11-libs/tslib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>embedded</herd>
+ <upstream>
+ <remote-id type="github">kergoth/tslib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-libs/tslib/tslib-1.0-r3.ebuild b/x11-libs/tslib/tslib-1.0-r3.ebuild
new file mode 100644
index 000000000000..72df67001d22
--- /dev/null
+++ b/x11-libs/tslib/tslib-1.0-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs autotools multilib-minimal
+
+PATCH_VER="5"
+DESCRIPTION="Touchscreen Access Library"
+HOMEPAGE="https://github.com/kergoth/tslib"
+SRC_URI="http://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+#extras arctic2 collie corgi h3600 linear-h2200 mk712 ucb1x00"
+
+DOCS=( AUTHORS NEWS README )
+
+src_prepare() {
+ # patches come from buildroot + openembedded + suse
+ EPATCH_SUFFIX=patch epatch "${WORKDIR}"/patch
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # compile everything. INSTALL_MASK= what you don't want.
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-linear --enable-dejitter \
+ --enable-variance --enable-pthres \
+ --enable-input --enable-shared \
+ --enable-arctic2 --enable-collie \
+ --enable-corgi --enable-h3600 \
+ --enable-linear-h2200 --enable-mk712 \
+ --enable-ucb1x00 --disable-debug
+}