summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/screengrab
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/screengrab')
-rw-r--r--x11-misc/screengrab/Manifest1
-rw-r--r--x11-misc/screengrab/files/screengrab-1.0-detect-lib64.patch27
-rw-r--r--x11-misc/screengrab/metadata.xml14
-rw-r--r--x11-misc/screengrab/screengrab-1.0.ebuild31
4 files changed, 73 insertions, 0 deletions
diff --git a/x11-misc/screengrab/Manifest b/x11-misc/screengrab/Manifest
new file mode 100644
index 000000000000..65e448d8a055
--- /dev/null
+++ b/x11-misc/screengrab/Manifest
@@ -0,0 +1 @@
+DIST screengrab-1.0.tar.gz 152250 SHA256 40babc5c1afc32e4f413ec56bfd2bf39bdb894ac32465b6cceec21520e60563f SHA512 e34e1fa907ccb105e1b37db40c2dfc22d19b8cdf517a73f4df11f3dffc2cdb0c6ed204d2d1c5bd8efeaa5326f52907fb4b364c84be510d392d7ff882f8d44a7e WHIRLPOOL cefb28f7d4ef29683389e4f4a2e12bb15af049e3c0834f6d53d04650b7b5128090defe5d0849bfdb417e534ccdac12ace73f72a70852f02681a58d35a4032f6b
diff --git a/x11-misc/screengrab/files/screengrab-1.0-detect-lib64.patch b/x11-misc/screengrab/files/screengrab-1.0-detect-lib64.patch
new file mode 100644
index 000000000000..308893d656e2
--- /dev/null
+++ b/x11-misc/screengrab/files/screengrab-1.0-detect-lib64.patch
@@ -0,0 +1,27 @@
+commit f613bc6d26095b891c7aa886de0bd6e5bfc5ce46
+Author: DOOMer <doomer3d@gmail.com>
+Date: Fri Aug 16 02:26:27 2013 +0400
+
+ Fix detect 'lib64' dir
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d31a477..c56d158 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -67,11 +67,13 @@ add_definitions( -DPREFIX="${CMAKE_INSTALL_PREFIX}")
+
+ message(STATUS "Install prefix: " ${CMAKE_INSTALL_PREFIX})
+
+-IF (IS64BITS AND RESPECTLIB64)
++string (COMPARE EQUAL "${CMAKE_SIZEOF_VOID_P}" "8" IS64BITS)
++
++IF (IS64BITS)
+ SET (LIBDIR "lib64")
+-ELSE (IS64BITS AND RESPECTLIB64)
++ELSE (IS64BITS )
+ SET (LIBDIR "lib")
+-ENDIF (IS64BITS AND RESPECTLIB64)
++ENDIF (IS64BITS )
+ set(SG_LIBDIR "${LIBDIR}/screengrab")
+ set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${SG_LIBDIR}")
+ message(STATUS "Library path: "${CMAKE_INSTALL_RPATH})
diff --git a/x11-misc/screengrab/metadata.xml b/x11-misc/screengrab/metadata.xml
new file mode 100644
index 000000000000..89e086cd0db1
--- /dev/null
+++ b/x11-misc/screengrab/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <upstream>
+ <remote-id type="google-code">screengrab-qt</remote-id>
+ </upstream>
+<upstream>
+ <maintainer status="active">
+ <email>doomer3d@gmail.com</email>
+ <name>Artem Galichkin</name>
+ </maintainer>
+</upstream>
+</pkgmetadata>
diff --git a/x11-misc/screengrab/screengrab-1.0.ebuild b/x11-misc/screengrab/screengrab-1.0.ebuild
new file mode 100644
index 000000000000..a503a4781cd9
--- /dev/null
+++ b/x11-misc/screengrab/screengrab-1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Qt application for getting screenshots"
+HOMEPAGE="http://screengrab.doomer.org"
+# Mirror the tarball because upstream failed to provide a proper way to get it
+SRC_URI="http://screengrab.doomer.org/download/screengrab-1_0_/ -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-detect-lib64.patch )
+
+src_prepare() {
+ # Install docs into the right dir, but skip the license.
+ sed -i -e "/SG_DOCDIR/s:screengrab:${PF}:" \
+ CMakeLists.txt || die
+ cmake-utils_src_prepare
+}