summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2018-02-23 11:36:06 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2018-02-23 14:49:10 +0100
commit9259d2b170567250a73486a65c0099220fb3bae9 (patch)
tree2052321d29f12b1a160703682771b4f20718bef4 /x11-misc/xplanetFX
parentmedia-gfx/displaycal: 3.5.0.0 bump (diff)
downloadgentoo-9259d2b170567250a73486a65c0099220fb3bae9.tar.gz
gentoo-9259d2b170567250a73486a65c0099220fb3bae9.tar.bz2
gentoo-9259d2b170567250a73486a65c0099220fb3bae9.zip
x11-misc/xplanetFX: 2.6.14 bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'x11-misc/xplanetFX')
-rw-r--r--x11-misc/xplanetFX/Manifest1
-rw-r--r--x11-misc/xplanetFX/xplanetFX-2.6.14.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/x11-misc/xplanetFX/Manifest b/x11-misc/xplanetFX/Manifest
index 65f8714b96ad..2471c3765652 100644
--- a/x11-misc/xplanetFX/Manifest
+++ b/x11-misc/xplanetFX/Manifest
@@ -1,2 +1,3 @@
DIST xplanetfx-2.6.12_all.tar.gz 36874773 BLAKE2B 12a3fb093584a978f559c64ca64ec567ebbb25faf081ca2b2bb4365aa187693b1dd5f1a3d88a57aa6c901b1c812c19fd6f717ca096093b02760af62d8a8f0fcc SHA512 b2d76f9a8341ab5098a3b09f27f7844673850275f4c577cef344199cdc72f93060eb05786a9111a1fb9f120d747f12cc5793dba6a249141e284a3bff59d4e0fe
DIST xplanetfx-2.6.13_all.tar.gz 36874849 BLAKE2B 276fbb61d6f90e5e0ed13eb7292d8f853eee8a8d92691d1b5502de6e51e526b36f916f5469eddf411ac8c8b876787c0989d82e8685d6374b36f385b1cb11f47b SHA512 dddc3666dd0f802cafd7b917eb513dd662b94617701622eabaaff18cf9277e3faf206eb602eb2af7c117a212b14e1cdbc4a8c11bded8243571ae4afa86f3fe72
+DIST xplanetfx-2.6.14_all.tar.gz 36874844 BLAKE2B ee02daa55fe2e0a64b4691c95e8bac1b95d99d0ddd1e83036d723d46140b54be8d859619815929e205bc386fd5dbe5ffdc8ca3995da73497e93ee79cccee1dfe SHA512 479c297906785f304178cd3ff41eaf955be6b6a50437c02528528f2328cc726bdcc54fedc107df02b346144c2f06a4325a40b94f03f7923081bed48baf0238b5
diff --git a/x11-misc/xplanetFX/xplanetFX-2.6.14.ebuild b/x11-misc/xplanetFX/xplanetFX-2.6.14.ebuild
new file mode 100644
index 000000000000..5a7eba008ee4
--- /dev/null
+++ b/x11-misc/xplanetFX/xplanetFX-2.6.14.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+DESCRIPTION="GUI to configure, run or daemonize xplanet with HQ capabilities"
+HOMEPAGE="http://mein-neues-blog.de/xplanetFX/"
+SRC_URI="http://repository.mein-neues-blog.de:9000/archive/${P/FX/fx}_all.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ media-gfx/imagemagick
+ sys-devel/bc
+ x11-misc/xplanet
+ libnotify? ( x11-libs/libnotify )"
+#python
+
+S="${WORKDIR}/usr"
+
+src_prepare() {
+ default
+
+ eapply "${FILESDIR}"/${PN}-2.6.4-gentoo-path.patch
+ sed -e "s/Application;//" -i share/applications/*desktop || die
+
+ # These will be installed separately
+ mkdir gentoo || die
+ mv share/${PN}/{autostart,flipview.py,stars/catalog.py,xplanetFX_gtk,xplanetFX_tray} \
+ gentoo || die
+}
+
+src_install() {
+ dobin bin/${PN}
+ insinto /usr/share/applications
+ doins share/applications/${PN}.desktop
+ insinto /usr/share/pixmaps
+ doins share/pixmaps/*
+ insinto /usr/share/${PN}
+ doins -r share/${PN}/*
+
+ exeinto /usr/share/${PN}
+ doexe gentoo/autostart
+
+ dodoc share/doc/${PN}/{changelog,README}
+
+ python_scriptinto /usr/share/${PN}/stars
+ python_foreach_impl python_doscript gentoo/catalog.py
+ python_scriptinto /usr/share/${PN}
+ python_foreach_impl python_doscript gentoo/{xplanetFX_gtk,xplanetFX_tray}
+ python_foreach_impl python_domodule gentoo/flipview.py
+}