summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-10-25 17:46:30 -0400
committerMatt Turner <mattst88@gentoo.org>2020-10-25 17:56:36 -0400
commit4ec252ae891fddecfcb5d1cf596f08d94c459c5a (patch)
tree634d59412bc3c6c5a75a338bade42987040bf7be /x11-misc
parentdev-python/ansi2html: Stabilize 1.5.2-r2 ALLARCHES, #750605 (diff)
downloadgentoo-4ec252ae891fddecfcb5d1cf596f08d94c459c5a.tar.gz
gentoo-4ec252ae891fddecfcb5d1cf596f08d94c459c5a.tar.bz2
gentoo-4ec252ae891fddecfcb5d1cf596f08d94c459c5a.zip
x11-misc/xkeyboard-config: Version bump to 2.31
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xkeyboard-config/Manifest1
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.31.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/x11-misc/xkeyboard-config/Manifest b/x11-misc/xkeyboard-config/Manifest
index 9a8ef99b2bb0..a3558a03e45b 100644
--- a/x11-misc/xkeyboard-config/Manifest
+++ b/x11-misc/xkeyboard-config/Manifest
@@ -1 +1,2 @@
DIST xkeyboard-config-2.30.tar.bz2 1689137 BLAKE2B 54ba0a3a82d65f4cf15c45aa500bd8a44865c9ce845d5bc1ae85d3544a384622c580baa119b8882defa9868d8210697153f868a273a38852d938bf318ed09c3b SHA512 2d775dcaab49d80f62b8eaadc9be406b42c9a3643d3a360f864a462c61865abce67d0a8a80772d54f8136603114c61b5168fd06771f9c132411911914abb1ea4
+DIST xkeyboard-config-2.31.tar.bz2 1705328 BLAKE2B a6fe680a8f32f1ca58363faeb0955ae621712f045570f66ce1c211093f0021f60e7fa29076b9dac80ee6c07ef1e4abb738ad64fd01a75ad776e582e2dbcc286e SHA512 f6f260253e1757640cc0591f9efb55ad5d08023a53ec2f0b468465b36bae0aae4f78dc4d6e603c95aa21c9993d9a42bd641edf2017be3183921a0b1c125f4669
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.31.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.31.ebuild
new file mode 100644
index 000000000000..892bf38d0d17
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.31.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit python-any-r1
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config.git"
+ inherit autotools git-r3
+ # x11-misc/util-macros only required on live ebuilds
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+ SRC_URI="https://www.x.org/releases/individual/data/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+RDEPEND=""
+DEPEND="${LIVE_DEPEND}"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ --with-xkb-base="${EPREFIX}/usr/share/X11/xkb"
+ --enable-compat-rules
+ # do not check for runtime deps
+ --disable-runtime-deps
+ --with-xkb-rules-symlink=xorg
+ )
+
+ econf "${econfargs[@]}"
+}
+
+src_test() {
+ :;
+}