summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-07-28 12:22:59 +0200
committerJeroen Roovers <jer@gentoo.org>2018-07-28 12:36:54 +0200
commit83dfc011bcea933e0908b15bb0117ba5fff4845e (patch)
tree89c1fb9adbe89e0cdb5c7daeb8cd1eb637d6895b /x11-terms/guake
parentx11-plugins/wmclockmon: EAPI7, improve ebuild (diff)
downloadgentoo-83dfc011bcea933e0908b15bb0117ba5fff4845e.tar.gz
gentoo-83dfc011bcea933e0908b15bb0117ba5fff4845e.tar.bz2
gentoo-83dfc011bcea933e0908b15bb0117ba5fff4845e.zip
x11-terms/guake: Version 3.3.2.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'x11-terms/guake')
-rw-r--r--x11-terms/guake/Manifest1
-rw-r--r--x11-terms/guake/files/guake-3.3.2-paths.patch20
-rw-r--r--x11-terms/guake/guake-3.3.2.ebuild61
3 files changed, 82 insertions, 0 deletions
diff --git a/x11-terms/guake/Manifest b/x11-terms/guake/Manifest
index 10ca324039b0..247df385840f 100644
--- a/x11-terms/guake/Manifest
+++ b/x11-terms/guake/Manifest
@@ -1,3 +1,4 @@
DIST guake-0.8.13.tar.gz 410816 BLAKE2B 37240d5f86cee596243a23ce47c3d3502cc889dc90d98e8a073325bd8c7fb74929308b5f91756100b2bd641134992e61ec833581380b3733613cf83526e26e92 SHA512 89c21bab2b1e5fc17c16349e4a4a4e8d089b084ddffedcf7a20aa059d4269a2a1c5754ec7b343f4f0e2ffae135b78a6128b8c14642f50645ddd52f700fd82a38
DIST guake-0.8.8.tar.gz 395143 BLAKE2B 34b47948fd03e3187ca5cad4697b0bffd81f5c1add3951a42904837075768bc9f39a278a0e0e3bd555e1d3a9814efd5aefae3c1baa9fac98108eb6dfc81f6035 SHA512 cbff208ea985669c5063793aaa74504a0de92127b52af23499b7c95df7c3841558ae61586e56771ce8e0d444bbe95a95e12e1af41f8a4ac9c74c13b3e9df8dc2
DIST guake-3.3.0.tar.gz 1006849 BLAKE2B 387ca17a881beebb84c81fda29a3f44ab3f297841010128bc4c5c4eded83d3325562bc88858fd1a8824a7c26d3bb9050bbe17399934f6e6cdcf8b4bf3c15d8a6 SHA512 1558e34f29060e449d676077c90df92ea9bc3a57857094be8d98cd283010de1125b7eeb3fbc3b3fcd08cacac9cf8ee461adb28cc29c491e8d2c3ad32fa39754b
+DIST guake-3.3.2.tar.gz 1084094 BLAKE2B b534ed18a6b9ad686fbe41fe1aa6e522429a50725103455cc5ccc5c4c7b67df6ce9eeac3c769ef3cb44bcc2e60305df80b6aa6af83c89a27b290e5ea48d19f8e SHA512 4d5585178d1e70d5b954071c4b68af22c459518df7af5930bd9a44f1f63afaff7b89bcab43422f9ae178c1dccf1268e5555d5776adb01fc8f11666dae2c3e766
diff --git a/x11-terms/guake/files/guake-3.3.2-paths.patch b/x11-terms/guake/files/guake-3.3.2-paths.patch
new file mode 100644
index 000000000000..d2d94daa4b1a
--- /dev/null
+++ b/x11-terms/guake/files/guake-3.3.2-paths.patch
@@ -0,0 +1,20 @@
+--- a/Makefile
++++ b/Makefile
+@@ -81,7 +81,7 @@
+
+ @if [ -f guake/paths.py.dev ]; then rm -f guake/paths.py.dev; fi
+ @if [ -f guake/paths.py ]; then mv guake/paths.py guake/paths.py.dev; fi
+- @cp -f guake/paths.py.in guake/paths.py
++ -@cp -f guake/paths.py.in guake/paths.py
+ @sed -i -e 's|{{ LOCALE_DIR }}|"$(localedir)"|g' guake/paths.py
+ @sed -i -e 's|{{ IMAGE_DIR }}|"$(IMAGE_DIR)"|g' guake/paths.py
+ @sed -i -e 's|{{ GLADE_DIR }}|"$(GLADE_DIR)"|g' guake/paths.py
+@@ -368,7 +368,7 @@
+
+ generate-paths:
+ @echo "Generating path.py..."
+- @cp -f guake/paths.py.in guake/paths.py
++ -@cp -f guake/paths.py.in guake/paths.py
+ @# Generic
+ @sed -i -e 's|{{ LOGIN_DESTOP_PATH }}|""|g' guake/paths.py
+ @sed -i -e 's|{{ AUTOSTART_FOLDER }}|""|g' guake/paths.py
diff --git a/x11-terms/guake/guake-3.3.2.ebuild b/x11-terms/guake/guake-3.3.2.ebuild
new file mode 100644
index 000000000000..cb6f65d97f38
--- /dev/null
+++ b/x11-terms/guake/guake-3.3.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 gnome2-utils xdg-utils
+
+DESCRIPTION="Drop-down terminal for GNOME"
+HOMEPAGE="https://github.com/Guake/guake https://pypi.org/project/Guake"
+SRC_URI="mirror://pypi/${PN^:0:1}/${PN^}/${P^}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="utempter"
+
+RDEPEND="
+ dev-libs/keybinder:3
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/libnotify
+ x11-libs/vte:2.91
+ utempter? ( sys-libs/libutempter )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas
+ sys-devel/gettext
+ sys-devel/make
+"
+
+S="${WORKDIR}/${P^}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3.2-paths.patch
+)
+
+python_compile_all() {
+ emake prepare-install prefix=/usr
+ emake generate-paths prefix=/usr DATA_DIR='$(datadir)/guake' DEV_SCHEMA_DIR='$(gsettingsschemadir)'
+ default
+}
+
+python_install_all() {
+ emake install-schemas install-locale prefix=/usr DESTDIR="${D}"
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}