summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2020-02-18 21:03:31 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-02-18 22:17:37 +0100
commit27e37bd238eabecf227cd819863d2aab0bd02927 (patch)
treeb70230e9c780b016c6456684526286c94d7e12fb /x11-wm
parentapp-arch/cpio: backport tweak for gcc-10, bug #705900 (diff)
downloadgentoo-27e37bd238eabecf227cd819863d2aab0bd02927.tar.gz
gentoo-27e37bd238eabecf227cd819863d2aab0bd02927.tar.bz2
gentoo-27e37bd238eabecf227cd819863d2aab0bd02927.zip
x11-wm/i3: Bump to v4.18
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Nelo-T. Wallus <nelo@wallus.de> Closes: https://github.com/gentoo/gentoo/pull/14695 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/i3/Manifest1
-rw-r--r--x11-wm/i3/i3-4.18.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/x11-wm/i3/Manifest b/x11-wm/i3/Manifest
index 29255354a407..648ca3b2b7d4 100644
--- a/x11-wm/i3/Manifest
+++ b/x11-wm/i3/Manifest
@@ -3,3 +3,4 @@ DIST i3-4.15.tar.bz2 1196263 BLAKE2B 36f20327202957dba30aface91af4d2c6261979e726
DIST i3-4.16.1.tar.bz2 1211532 BLAKE2B 64a6996c0b89516069b58bf1cba92908a7f61ab04d66659b612b27411eb92fa9d49a7214eccdba33e7c33605b5f9247f69c1f0e23de629552edf113ab7520747 SHA512 3e328f8c7216697c5e484ca854605350f78844e24cc6cfb9c10e71368c2c0457387a14f819abdf8be2370d437889297f452fbf63f3924766ca81c157ab27e1b0
DIST i3-4.16.tar.bz2 1213251 BLAKE2B a65d15278a83bac9903a611628ea53c64cd554ab9fff2a8864e649fd962858b2f3e77fe69d0dc70affc93dc69b3cbbd7b3ee670a2af9d697e28e9e4ea3323f67 SHA512 99abd15349ee8e61c084b3664ef3a189c92ea07812ac59eb6a5441df7cebea8211be52204e39bddcc33d8c714447fddbbe2c5c8a25b756a96e2dc6732526cbf8
DIST i3-4.17.1.tar.bz2 1218418 BLAKE2B eb798eee2b618691ceb47b72c08fe09b09e2913c17fe667fab95426069c86497bff67278bea5fc97fdf90ebdfc6574e68cad36b21036a63d053edced1edf8592 SHA512 af397dc1768ea6530e4b2ce8ef21b20ecff8ab9eebf380df224456173eea4c3bacf28b55c8efcdc70f76f0d66543c163564a94cfd66028221ace481fa3c2913f
+DIST i3-4.18.tar.bz2 1218591 BLAKE2B 582b7ba3a54edf8dd2657add05eb54a64b7c004761a1a248d91dfcb061cb9df215ff35301c125b11aa69b571daeacd5732b498934c1fb17f69404a101fd16ec8 SHA512 0bbfda7f4b20a92a50ffb6abbfc3f6bfe6bb4c987ad4b5b1791192eb23b8c3389cc9949a699901797370c14de1ff8e12447a3b8ce330ab7d300fafdb60a432ec
diff --git a/x11-wm/i3/i3-4.18.ebuild b/x11-wm/i3/i3-4.18.ebuild
new file mode 100644
index 000000000000..d7064cfb971e
--- /dev/null
+++ b/x11-wm/i3/i3-4.18.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools out-of-source virtualx
+
+DESCRIPTION="An improved dynamic tiling window manager"
+HOMEPAGE="https://i3wm.org/"
+SRC_URI="https://i3wm.org/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc debug test"
+
+CDEPEND="dev-libs/libev
+ dev-libs/libpcre
+ dev-libs/yajl
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbcommon[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+ x11-misc/xkeyboard-config
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/pango[X]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-perl/AnyEvent
+ dev-perl/X11-XCB
+ dev-perl/Inline
+ dev-perl/Inline-C
+ dev-perl/IPC-Run
+ dev-perl/ExtUtils-PkgConfig
+ dev-perl/local-lib
+ virtual/perl-Test-Simple
+ x11-base/xorg-server[xephyr]
+ x11-misc/xvfb-run
+ )"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+ dev-perl/AnyEvent-I3
+ dev-perl/JSON-XS"
+BDEPEND="virtual/pkgconfig"
+
+# Test without debug will apply optimization levels, which results
+# in type-punned pointers - which in turn causes test failures.
+REQUIRED_USE="test? ( debug )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.16-musl-GLOB_TILDE.patch"
+)
+
+# https://github.com/i3/i3/issues/3013
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ cat <<- EOF > "${T}"/i3wm
+ #!/bin/sh
+ exec /usr/bin/i3
+ EOF
+
+ eautoreconf
+}
+
+my_src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+my_src_test() {
+ emake check
+}
+
+my_src_install_all() {
+ doman man/*.1
+
+ einstalldocs
+ use doc && dodoc -r docs "RELEASE-NOTES-${PV}"
+
+ exeinto /etc/X11/Sessions
+ doexe "${T}/i3wm"
+}
+
+pkg_postinst() {
+ # Only show the elog information on a new install
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "There are several packages that you may find useful with ${PN} and"
+ elog "their usage is suggested by the upstream maintainers, namely:"
+ elog " x11-misc/dmenu"
+ elog " x11-misc/i3status"
+ elog " x11-misc/i3lock"
+ elog "Please refer to their description for additional info."
+ fi
+}