summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-15 15:37:06 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-15 16:03:54 +0100
commit0440f0c3daa68422f8be30639f260b5f23c8de0a (patch)
tree1774163a561b37990d17115310fca062a14dd64c /xfce-base/exo
parentxfce-base/exo: Remove old (diff)
downloadgentoo-0440f0c3daa68422f8be30639f260b5f23c8de0a.tar.gz
gentoo-0440f0c3daa68422f8be30639f260b5f23c8de0a.tar.bz2
gentoo-0440f0c3daa68422f8be30639f260b5f23c8de0a.zip
xfce-base/exo: Bump to 4.18.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-4.18.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 9d7e65c6ccf6..d2f4dc2f922f 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,2 +1,3 @@
DIST exo-4.16.4.tar.bz2 876080 BLAKE2B a29511c0d2e1bbbd861cfd8946d2f2917eb1004bb85621d0bb8bb9b1339f213a14da651e16a6492138cceff8e3e0ec1d1132226ac60a9846426bf6dc2a621ded SHA512 2cf2267a0bd8526dc870cbe48a0d95573c153a990caffabb13365c6e90c155b6d3383ad1282715cb22ce413e704d170bf7fec1af09ad1b0609507a46c4d1233d
DIST exo-4.17.4.tar.bz2 895388 BLAKE2B a48f2c7f1509a41d74b924c428fd57b4801b9e45dfa86a2b300ed5b296f5b4bda489e0e71e10a3dd9720b2164ac0debd3ec86a081413f2157637fed80fa819a7 SHA512 b4d7308931b286ae9ab296970a1de924a5da515032b50a594b564c60b1d7d50c06896615f8b3dc986bd1e44feeddc656fa3788bb745e93162231257fffc90c0c
+DIST exo-4.18.0.tar.bz2 896849 BLAKE2B 99cd22b9f2c806907449afdd640abd85be2ec37269d0436a20300ac88ee4fbe39807e39ba51ae8fe82d621c478d65d1f452209779e7d48caee899305b40f3a27 SHA512 32f3a319ff31a37cdaf8e2e7bdbdbaa9b797d6731a27854838b47d6078f45af83ed1a664aef4663f616fd9abcae9233c6f68ab2cc18599f1b2ced487602c51ce
diff --git a/xfce-base/exo/exo-4.18.0.ebuild b/xfce-base/exo/exo-4.18.0.ebuild
new file mode 100644
index 000000000000..c32a1a6877c5
--- /dev/null
+++ b/xfce-base/exo/exo-4.18.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/exo/start
+ https://gitlab.xfce.org/xfce/exo/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=xfce-base/libxfce4ui-4.15.1:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.17.2:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ >=dev-util/xfce4-dev-tools-4.16.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}