summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-16 00:58:03 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-16 00:58:03 +0100
commit4ebed096fbf817c6cf6dac2446dbcec9d1b7a3d4 (patch)
tree47a90f5ff404f5c6e5adad061709768db9659f06 /xfce-base/exo
parentdev-python/flaky: Fix remaining MissingTestRestrict (diff)
downloadgentoo-4ebed096fbf817c6cf6dac2446dbcec9d1b7a3d4.tar.gz
gentoo-4ebed096fbf817c6cf6dac2446dbcec9d1b7a3d4.tar.bz2
gentoo-4ebed096fbf817c6cf6dac2446dbcec9d1b7a3d4.zip
xfce-base/exo: Bump to 0.12.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-0.12.9.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 60786eb3dfbb..07ce1f73e703 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,2 +1,3 @@
DIST exo-0.12.4.tar.bz2 1235738 BLAKE2B f05ae13bb5ec599686207df3fe7458b8a42227194c91c24397ed282d2c7a6ccf10989f14c662f2e0d986c59695de2b8d50743c8489bc716aaa001cbd23fe3598 SHA512 8f84258aeb5c1fcfe91e775af1e5fed02f36b3d18aa72d497cd05294d54f050d679628cdb4339219c67b203a8cc663704a240fc18e6a918cef363cf4d9b94783
DIST exo-0.12.8.tar.bz2 1342201 BLAKE2B 6f52072f169a48ace6490d4c272e7e1208ca66efc388c8706b183d8ebe908d2fc305ae0239647e96e860eaacb1fbc440fc8dd559757f29088548c95702b1401e SHA512 5b96f1e3ba7112d349ee7d986288996c52210304d0aa54594fdc8c85ec0b12e13791f320f28e91bd25afda5f1046f402ba4fcf2eca5df5d8fc0c3515cd6b98a3
+DIST exo-0.12.9.tar.bz2 1333477 BLAKE2B 18b6892b32ff65350b9e64be8190a5d6ca3637c97ba1449e7e511c1efaf081a308c9a0796d845d0069186f85dc775f9196703a1f0a97c16de7bbae6aa94a47d8 SHA512 ae0e893c595553ff9db15967419ffd9d78ec6ab6dbcefcc02536367e04cc4db51d41305f0f527778ba9b8b04cb51bd560bff07ef5ba3a56d1acab1d1730e7ee7
diff --git a/xfce-base/exo/exo-0.12.9.ebuild b/xfce-base/exo/exo-0.12.9.ebuild
new file mode 100644
index 000000000000..77319c3c1ace
--- /dev/null
+++ b/xfce-base/exo/exo-0.12.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="gtk2"
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.42
+ dev-perl/URI
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:=
+ gtk2? ( >=x11-libs/gtk+-2.24:2 )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable gtk2)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}