summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-01 14:32:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-01 14:32:54 +0100
commit58cb1eaac1c501c8f0c390c44901d701f7c6de85 (patch)
tree6a3fa64a93eb5127a00177ef37cb67f0e79711e4 /xfce-base/exo
parentxfce-base/thunar-volman: Bump to 4.17.1 (diff)
downloadgentoo-58cb1eaac1c501c8f0c390c44901d701f7c6de85.tar.gz
gentoo-58cb1eaac1c501c8f0c390c44901d701f7c6de85.tar.bz2
gentoo-58cb1eaac1c501c8f0c390c44901d701f7c6de85.zip
xfce-base/exo: Bump to 4.17.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-4.17.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 15a34cf8df9d..71e45657fcae 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,3 +1,4 @@
DIST exo-4.16.4.tar.bz2 876080 BLAKE2B a29511c0d2e1bbbd861cfd8946d2f2917eb1004bb85621d0bb8bb9b1339f213a14da651e16a6492138cceff8e3e0ec1d1132226ac60a9846426bf6dc2a621ded SHA512 2cf2267a0bd8526dc870cbe48a0d95573c153a990caffabb13365c6e90c155b6d3383ad1282715cb22ce413e704d170bf7fec1af09ad1b0609507a46c4d1233d
DIST exo-4.17.2.tar.bz2 878021 BLAKE2B 2756a032be106f371de17cf2c862acecb1a1a264f7f91b4c452d6a0cc8addc93ebf918b5e2e17baa1a78e8dc3bca6fde505d994fb3258a2bcceeb49899cd3b6c SHA512 99d688f9dc2f1a66f546943780521572d3df689e616b75a2a1e26a1d8c95b534175f6bc9a1a1782a7ffb8c09fa40e649ee6d688105344c748775ee3fdd10d1d0
DIST exo-4.17.3.tar.bz2 895012 BLAKE2B 473a36867103ae9d0e2a16f142e94a6d2238efb70d908fe343cd426808a3f8ce520e922b8b50e9eb20f42be31c31ffa0231f859aa885cbf3d36db61f9e880956 SHA512 c80c75e8a2fda3b9ca7d522197ddbc5c031e7c2eaa6183687f5b3afa049af6c7892e435c343652f2105cbcd4f1d75776c816740f32df29db105ebe3fb616ef49
+DIST exo-4.17.4.tar.bz2 895388 BLAKE2B a48f2c7f1509a41d74b924c428fd57b4801b9e45dfa86a2b300ed5b296f5b4bda489e0e71e10a3dd9720b2164ac0debd3ec86a081413f2157637fed80fa819a7 SHA512 b4d7308931b286ae9ab296970a1de924a5da515032b50a594b564c60b1d7d50c06896615f8b3dc986bd1e44feeddc656fa3788bb745e93162231257fffc90c0c
diff --git a/xfce-base/exo/exo-4.17.4.ebuild b/xfce-base/exo/exo-4.17.4.ebuild
new file mode 100644
index 000000000000..510712a94c77
--- /dev/null
+++ b/xfce-base/exo/exo-4.17.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/exo/start
+ https://gitlab.xfce.org/xfce/exo/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.66
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.15.1:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.17.2:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ >=dev-util/xfce4-dev-tools-4.16.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}