summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-06 04:03:47 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-06 04:07:42 +0100
commitba36083fe46b456a7eb53a055654cd8c2ba738f5 (patch)
treeb32627b51d4e13085960d2997196603a3942b252 /xfce-base/libxfce4ui
parentxfce-base/libxfce4ui: Bump to 4.19.4 (diff)
downloadgentoo-ba36083fe46b456a7eb53a055654cd8c2ba738f5.tar.gz
gentoo-ba36083fe46b456a7eb53a055654cd8c2ba738f5.tar.bz2
gentoo-ba36083fe46b456a7eb53a055654cd8c2ba738f5.zip
xfce-base/libxfce4ui: Bump to 4.18.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/libxfce4ui')
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.18.5.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index 2656ed10a8aa..ed1ba96df2ef 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,3 +1,4 @@
DIST libxfce4ui-4.18.4.tar.bz2 907248 BLAKE2B 785ec91bcb2995d289423ac666832b642e1cd1c2685e9bb5b6781ca6c7272d7e85e163a55b137602401ed9a18f1b8e29492e3b7bd1d74951544e71a4338860ae SHA512 e931d38319bcc0dcfa854642f604fcd782ffb27a160ae7e2625d7a276625635131b0451c12ccd502b68366283c503ad21536389e70da6912e46eb16b97f28642
+DIST libxfce4ui-4.18.5.tar.bz2 906155 BLAKE2B 2fb977ecbb6c02c485ed2575d189140c5cdce4090529aabbd6a220986cb53241aecfa3a1d1ed79ae873a53d14fa6af80c0732050c6d6aace949e47ba2d71bf8f SHA512 b8b64bf2b71bc327a94c9292b6e1ad5647c6f91b3a806faad894d9973955ec3b05f14a28c0486604c518f7cef1f676337c1405f7d04a8b7b8698f1725346c0f5
DIST libxfce4ui-4.19.3.tar.bz2 1169903 BLAKE2B 175e88fa58712933c681a8851c787d7322d806005cd450e3db3d3a7744ea08a599ddba071944c031e047365c4fec70b0144f84a3ed491b9bd5efb7a359233303 SHA512 3361de52cd48318cdd5a61d26a741336f4168fa98a284faee5ac53460dc875625df73084aec65e8203cea7438f9b8bd64cfd456ab9803c330a554aa6f444529a
DIST libxfce4ui-4.19.4.tar.bz2 1177397 BLAKE2B e73cb1d8fb8ba12e71fcf100888b2e9fe26ae08a1bb09edba6f0dc8ad7db0d872722c44812c9dc65be0c2331b9364fe668aeb9bd16dce138e8cca0dcb771400e SHA512 81ce96954bc70b5d2dfbe3311c969ad36247057a5caed13c002a994140ba8a56f5c49cb7a12aaf41a7edc0986b06c1eb22cf3f3c67d02312a47356bd99767c8e
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.18.5.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.18.5.ebuild
new file mode 100644
index 000000000000..e3eda5880a06
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.18.5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/libxfce4ui/start
+ https://gitlab.xfce.org/xfce/libxfce4ui/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="glade +introspection startup-notification system-info vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3[introspection?,X]
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.17.2:=[introspection?,vala?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+ startup-notification? ( x11-libs/startup-notification )
+ system-info? (
+ dev-libs/libgudev
+ gnome-base/libgtop
+ >=media-libs/libepoxy-1.2
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable system-info glibtop)
+ $(use_enable system-info epoxy)
+ $(use_enable system-info gudev)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}