summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /xfce-extra/xfce4-sensors-plugin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'xfce-extra/xfce4-sensors-plugin')
-rw-r--r--xfce-extra/xfce4-sensors-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-sensors-plugin/metadata.xml8
-rw-r--r--xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.5.ebuild63
-rw-r--r--xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.6.ebuild61
4 files changed, 134 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-sensors-plugin/Manifest b/xfce-extra/xfce4-sensors-plugin/Manifest
new file mode 100644
index 000000000000..84748dfc7d5b
--- /dev/null
+++ b/xfce-extra/xfce4-sensors-plugin/Manifest
@@ -0,0 +1,2 @@
+DIST xfce4-sensors-plugin-1.2.5.tar.bz2 399758 SHA256 6b3c12917116c0610c0ca0824357afcc4ab4553301241e27aa9665159b834c1e SHA512 240514c1e2150ccb2416f77a97039939884fb3ebde4b784136a69c8326caf48f1b29dd7dd49f8660deea42efde4cb34cce968c70944033562983ca180d0205cc WHIRLPOOL 032a60d6004b136eb3b9f69bfeb6f8b9fcbb466965e5c8585e40944f5dbf07eff02587d6ae181727ee9de7b79e24602956c92c55287d64de489c33171a9a3ddd
+DIST xfce4-sensors-plugin-1.2.6.tar.bz2 454524 SHA256 235ef842bd45e701bceebb21a384ab09f21afceea8ed95f91bb4c6cf3abe1bc0 SHA512 5c520f1c253df1bb9e29855c5ccfc1536034945ca68b43cd8b6d97083e528b2430230d9c51d43953a71c3f0171ae718bf1557714729b1343ebd51f91f3f36d60 WHIRLPOOL 60b1069b621026f37637ca93a5c8a956eb77ee234df472fef9c2f3bec56efc5f09d923e23fd7ab8ed76526a14ad414b3d82f2c2c2d7ab68118b4bafbe4add9f0
diff --git a/xfce-extra/xfce4-sensors-plugin/metadata.xml b/xfce-extra/xfce4-sensors-plugin/metadata.xml
new file mode 100644
index 000000000000..008cf479f615
--- /dev/null
+++ b/xfce-extra/xfce4-sensors-plugin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.5.ebuild b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.5.ebuild
new file mode 100644
index 000000000000..31553a37df47
--- /dev/null
+++ b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EAUTORECONF=yes
+inherit multilib xfconf
+
+DESCRIPTION="A panel plug-in for different sensors using acpi, lm_sensors and hddtemp"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="+acpi debug hddtemp libnotify lm_sensors video_cards_nvidia"
+
+REQUIRED_USE="|| ( hddtemp lm_sensors acpi )"
+
+RDEPEND=">=x11-libs/gtk+-2.14:2
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/xfce4-panel-4.8
+ hddtemp? ( app-admin/hddtemp net-analyzer/gnu-netcat )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ lm_sensors? ( >=sys-apps/lm_sensors-3.1.0 )
+ video_cards_nvidia? ( media-video/nvidia-settings )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable lm_sensors libsensors)
+ $(use_enable hddtemp)
+ $(use_enable hddtemp netcat)
+ $(use_enable acpi procacpi)
+ $(use_enable acpi sysfsacpi)
+ $(use_enable video_cards_nvidia xnvctrl)
+ $(use_enable libnotify notification)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS NOTES README TODO )
+}
+
+src_prepare() {
+ sed -i -e '/-no-undefined/d' src/Makefile.am || die
+
+ # Use flags from xfce4-dev-tools instead of defining them again in
+ # configure.in wrt #386979
+ # Remove AC_PROG_LIBTOOL because LT_INIT([disable-static]) is also present:
+ # http://bugzilla.xfce.org/show_bug.cgi?id=8888
+ # Use AC_CONFIG_HEADERS for automake-1.13 compability, see:
+ # http://bugzilla.xfce.org/show_bug.cgi?id=10031
+ sed -i \
+ -e '/PLATFORM_CFLAGS/s:-Werror::' \
+ -e '/AC_PROG_LIBTOOL/d' \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
+ configure.in || die
+
+ xfconf_src_prepare
+}
diff --git a/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.6.ebuild b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.6.ebuild
new file mode 100644
index 000000000000..6ba2485ec59c
--- /dev/null
+++ b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EAUTORECONF=yes
+inherit multilib xfconf
+
+DESCRIPTION="A panel plug-in for different sensors using acpi, lm_sensors and hddtemp"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="+acpi debug hddtemp libnotify lm_sensors video_cards_nvidia"
+
+REQUIRED_USE="|| ( hddtemp lm_sensors acpi )"
+
+RDEPEND=">=x11-libs/gtk+-2.14:2=
+ >=xfce-base/libxfce4ui-4.8:=
+ >=xfce-base/xfce4-panel-4.8:=
+ hddtemp? ( app-admin/hddtemp net-analyzer/gnu-netcat )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ lm_sensors? ( >=sys-apps/lm_sensors-3.1.0:= )
+ video_cards_nvidia? ( media-video/nvidia-settings )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable lm_sensors libsensors)
+ $(use_enable hddtemp)
+ $(use_enable hddtemp netcat)
+ $(use_enable acpi procacpi)
+ $(use_enable acpi sysfsacpi)
+ $(use_enable video_cards_nvidia xnvctrl)
+ $(use_enable libnotify notification)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS NOTES README TODO )
+}
+
+src_prepare() {
+ sed -i -e '/-no-undefined/d' src/Makefile.am || die
+
+ # Use flags from xfce4-dev-tools instead of defining them again in
+ # configure.in wrt #386979
+ # Remove AC_PROG_LIBTOOL because LT_INIT([disable-static]) is also present:
+ # http://bugzilla.xfce.org/show_bug.cgi?id=8888
+ # Use AC_CONFIG_HEADERS for automake-1.13 compability, see:
+ # http://bugzilla.xfce.org/show_bug.cgi?id=10031
+ sed -i \
+ -e '/PLATFORM_CFLAGS/s:-Werror::' \
+ configure.ac || die
+
+ xfconf_src_prepare
+}