summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /xfce-extra/xfce4-volumed-pulse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'xfce-extra/xfce4-volumed-pulse')
-rw-r--r--xfce-extra/xfce4-volumed-pulse/Manifest1
-rw-r--r--xfce-extra/xfce4-volumed-pulse/metadata.xml11
-rw-r--r--xfce-extra/xfce4-volumed-pulse/xfce4-volumed-pulse-0.2.0.ebuild33
3 files changed, 45 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-volumed-pulse/Manifest b/xfce-extra/xfce4-volumed-pulse/Manifest
new file mode 100644
index 000000000000..6b58be4c5d06
--- /dev/null
+++ b/xfce-extra/xfce4-volumed-pulse/Manifest
@@ -0,0 +1 @@
+DIST xfce4-volumed-pulse-0.2.0.tar.bz2 282403 SHA256 6930034a30bfa54106f3c76ea8e50f578426f5e6151c0e82fda04e6d127de550 SHA512 efa5bcb3558eda0b36f2bf0b737409571f69af7454f542a3dbd777e94d40b3f0107567d3fea3fc019b3eb77450b2bebde7aff8b72b0c30d2afd9a316e6ea77a6 WHIRLPOOL 1800a5e3db8e4a81a2c622aa9c33db4778391f253992056f3f4402ed337bce98c8e199d79b411e96d7d8abbb68a7d58d83471d3014dc9cbf367c87c6be26e091
diff --git a/xfce-extra/xfce4-volumed-pulse/metadata.xml b/xfce-extra/xfce4-volumed-pulse/metadata.xml
new file mode 100644
index 000000000000..4d7afe71423a
--- /dev/null
+++ b/xfce-extra/xfce4-volumed-pulse/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">xfce4-volumed-pulse</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-volumed-pulse/xfce4-volumed-pulse-0.2.0.ebuild b/xfce-extra/xfce4-volumed-pulse/xfce4-volumed-pulse-0.2.0.ebuild
new file mode 100644
index 000000000000..e5b3a8b07eab
--- /dev/null
+++ b/xfce-extra/xfce4-volumed-pulse/xfce4-volumed-pulse-0.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Daemon to control volume up/down and mute keys for pulseaudio"
+HOMEPAGE="http://launchpad.net/xfce4-volumed-pulse"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug libnotify"
+
+RDEPEND=">=dev-libs/glib-2.16
+ dev-libs/keybinder:0
+ >=media-sound/pulseaudio-0.9.19[glib]
+ >=x11-libs/gtk+-2.20:2
+ >=xfce-base/xfconf-4.8
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable libnotify)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog README THANKS )
+}