summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/seamonkey/files/seamonkey-gcc9.patch22
-rw-r--r--www-client/seamonkey/seamonkey-2.49.9.1_p0.ebuild5
2 files changed, 26 insertions, 1 deletions
diff --git a/www-client/seamonkey/files/seamonkey-gcc9.patch b/www-client/seamonkey/files/seamonkey-gcc9.patch
new file mode 100644
index 000000000000..87d14e6a16c4
--- /dev/null
+++ b/www-client/seamonkey/files/seamonkey-gcc9.patch
@@ -0,0 +1,22 @@
+--- a/mozilla/js/xpconnect/src/XPCWrappedNative.cpp.ORIG 2018-07-09 21:54:43.000000000 +0200
++++ b/mozilla/js/xpconnect/src/XPCWrappedNative.cpp 2019-05-04 17:49:23.893560494 +0200
+@@ -2218,15 +2218,16 @@
+ const char* fmt = (i == 0) ?
+ "(%s" : (i == count-1) ?
+ ", %s)" : ", %s";
++
++ if (!name) {
++ return nullptr;
++ }
+ name = JS_sprintf_append(name, fmt,
+ array[i]->GetNameString());
+ }
+ }
+ }
+
+- if (!name) {
+- return nullptr;
+- }
+ const char* fmt = "[xpconnect wrapped %s" FMT_ADDR FMT_STR(" (native")
+ FMT_ADDR FMT_STR(")") "]";
+ if (si) {
diff --git a/www-client/seamonkey/seamonkey-2.49.9.1_p0.ebuild b/www-client/seamonkey/seamonkey-2.49.9.1_p0.ebuild
index 05e55c8f784d..4b7e0269c381 100644
--- a/www-client/seamonkey/seamonkey-2.49.9.1_p0.ebuild
+++ b/www-client/seamonkey/seamonkey-2.49.9.1_p0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -156,6 +156,9 @@ src_prepare() {
eapply "${WORKDIR}"/firefox
popd &>/dev/null || die
+ # gcc9 patch #685092
+ eapply "${FILESDIR}"/${PN}-gcc9.patch
+
if grep -q '^sdkdir.*$(MOZ_APP_NAME)-devel' mozilla/config/baseconfig.mk ; then
sed '/^sdkdir/s@-devel@@' \
-i mozilla/config/baseconfig.mk || die