summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/redis/redis-4.0.14.ebuild9
-rw-r--r--dev-db/redis/redis-5.0.4.ebuild9
2 files changed, 10 insertions, 8 deletions
diff --git a/dev-db/redis/redis-4.0.14.ebuild b/dev-db/redis/redis-4.0.14.ebuild
index 1f0ac4ef03da..5f2c18f61cbc 100644
--- a/dev-db/redis/redis-4.0.14.ebuild
+++ b/dev-db/redis/redis-4.0.14.ebuild
@@ -23,13 +23,14 @@ RDEPEND="
tcmalloc? ( dev-util/google-perftools )
jemalloc? ( >=dev-libs/jemalloc-3.2 )"
-DEPEND="
- ${RDEPEND}
- test? ( dev-lang/tcl:0= )"
-
BDEPEND="
+ ${RDEPEND}
virtual/pkgconfig"
+# Tcl is only needed in the CHOST test env
+DEPEND="${RDEPEND}
+ test? ( dev-lang/tcl:0= )"
+
REQUIRED_USE="?? ( tcmalloc jemalloc )"
pkg_setup() {
diff --git a/dev-db/redis/redis-5.0.4.ebuild b/dev-db/redis/redis-5.0.4.ebuild
index ec8944b4940a..519fc3837ca9 100644
--- a/dev-db/redis/redis-5.0.4.ebuild
+++ b/dev-db/redis/redis-5.0.4.ebuild
@@ -23,13 +23,14 @@ RDEPEND="
tcmalloc? ( dev-util/google-perftools )
jemalloc? ( >=dev-libs/jemalloc-5.1:= )"
-DEPEND="
- ${RDEPEND}
- test? ( dev-lang/tcl:0= )"
-
BDEPEND="
+ ${RDEPEND}
virtual/pkgconfig"
+# Tcl is only needed in the CHOST test env
+DEPEND="${RDEPEND}
+ test? ( dev-lang/tcl:0= )"
+
REQUIRED_USE="?? ( tcmalloc jemalloc )"
pkg_setup() {