summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.10.9999.ebuild3
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild3
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild3
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.13.9999.ebuild3
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.14.9999.ebuild1
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.4.9999.ebuild3
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.9.9999.ebuild3
7 files changed, 13 insertions, 6 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.10.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.10.9999.ebuild
index ab52cf36414d..11c6e6acc9be 100644
--- a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.10.9999.ebuild
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.10.9999.ebuild
@@ -12,8 +12,9 @@ detect_version
detect_arch
inherit git-r3 versionator
-EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git -> raspberrypi-linux.git"
EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+EGIT_CHECKOUT_DIR="${WORKDIR}/linux-${PV}-raspberrypi"
DESCRIPTION="Raspberry PI kernel sources"
HOMEPAGE="https://github.com/raspberrypi/linux"
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild
index ab52cf36414d..11c6e6acc9be 100644
--- a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild
@@ -12,8 +12,9 @@ detect_version
detect_arch
inherit git-r3 versionator
-EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git -> raspberrypi-linux.git"
EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+EGIT_CHECKOUT_DIR="${WORKDIR}/linux-${PV}-raspberrypi"
DESCRIPTION="Raspberry PI kernel sources"
HOMEPAGE="https://github.com/raspberrypi/linux"
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild
index ab52cf36414d..11c6e6acc9be 100644
--- a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild
@@ -12,8 +12,9 @@ detect_version
detect_arch
inherit git-r3 versionator
-EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git -> raspberrypi-linux.git"
EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+EGIT_CHECKOUT_DIR="${WORKDIR}/linux-${PV}-raspberrypi"
DESCRIPTION="Raspberry PI kernel sources"
HOMEPAGE="https://github.com/raspberrypi/linux"
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.13.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.13.9999.ebuild
index ab52cf36414d..11c6e6acc9be 100644
--- a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.13.9999.ebuild
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.13.9999.ebuild
@@ -12,8 +12,9 @@ detect_version
detect_arch
inherit git-r3 versionator
-EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git -> raspberrypi-linux.git"
EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+EGIT_CHECKOUT_DIR="${WORKDIR}/linux-${PV}-raspberrypi"
DESCRIPTION="Raspberry PI kernel sources"
HOMEPAGE="https://github.com/raspberrypi/linux"
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.14.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.14.9999.ebuild
index 51bf6caa0a8e..11c6e6acc9be 100644
--- a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.14.9999.ebuild
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.14.9999.ebuild
@@ -14,6 +14,7 @@ detect_arch
inherit git-r3 versionator
EGIT_REPO_URI="https://github.com/raspberrypi/linux.git -> raspberrypi-linux.git"
EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+EGIT_CHECKOUT_DIR="${WORKDIR}/linux-${PV}-raspberrypi"
DESCRIPTION="Raspberry PI kernel sources"
HOMEPAGE="https://github.com/raspberrypi/linux"
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.4.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.4.9999.ebuild
index ab52cf36414d..11c6e6acc9be 100644
--- a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.4.9999.ebuild
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.4.9999.ebuild
@@ -12,8 +12,9 @@ detect_version
detect_arch
inherit git-r3 versionator
-EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git -> raspberrypi-linux.git"
EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+EGIT_CHECKOUT_DIR="${WORKDIR}/linux-${PV}-raspberrypi"
DESCRIPTION="Raspberry PI kernel sources"
HOMEPAGE="https://github.com/raspberrypi/linux"
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.9.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.9.9999.ebuild
index ab52cf36414d..11c6e6acc9be 100644
--- a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.9.9999.ebuild
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.9.9999.ebuild
@@ -12,8 +12,9 @@ detect_version
detect_arch
inherit git-r3 versionator
-EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git -> raspberrypi-linux.git"
EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+EGIT_CHECKOUT_DIR="${WORKDIR}/linux-${PV}-raspberrypi"
DESCRIPTION="Raspberry PI kernel sources"
HOMEPAGE="https://github.com/raspberrypi/linux"