summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/asymptote/Manifest1
-rw-r--r--media-gfx/asymptote/asymptote-2.32.ebuild213
2 files changed, 0 insertions, 214 deletions
diff --git a/media-gfx/asymptote/Manifest b/media-gfx/asymptote/Manifest
index 350f84b0254d..380dd1d36e3f 100644
--- a/media-gfx/asymptote/Manifest
+++ b/media-gfx/asymptote/Manifest
@@ -1,2 +1 @@
-DIST asymptote-2.32.src.tgz 1794495 BLAKE2B 3a633ba56159c1d67c667c2eff14840e539bcce38d2667175ec6ceb2ee4f271af3c0e24b8b1d1562e3919734dcb02431e4ca95d145dc42a3c144e1c291fadb03 SHA512 a0663f1768cb4340bb6e9224d4fbc6e2f8b41501b1f59793d84db2e0f99b9ff071d3dd8fa5c4715c1874f8ef1af713a54b27de37ff40d8ca042f0f48579a57f9
DIST asymptote-2.41.src.tgz 3516426 BLAKE2B d4623609be58566e32de82c5c47f635ed737459fa27cd2da0622d639cd8207fc69988a7ecbf82993b051435fbf223c1f1178d213aea258a2b57fd3a698eee9cb SHA512 93f737a44b085c2290c4553c765cf49679820e6623bc5b6d0229818409868876275d6f0571abeb76033955fa95ee594e37d10c9901c54755b085e36760fd96cb
diff --git a/media-gfx/asymptote/asymptote-2.32.ebuild b/media-gfx/asymptote/asymptote-2.32.ebuild
deleted file mode 100644
index 62de0fa52ae8..000000000000
--- a/media-gfx/asymptote/asymptote-2.32.ebuild
+++ /dev/null
@@ -1,213 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools elisp-common eutils latex-package multilib python-single-r1
-
-DESCRIPTION="A vector graphics language that provides a framework for technical drawing"
-HOMEPAGE="http://asymptote.sourceforge.net/"
-SRC_URI="mirror://sourceforge/asymptote/${P}.src.tgz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="+boehm-gc doc emacs examples fftw gsl +imagemagick latex offscreen +opengl python sigsegv svg vim-syntax X"
-
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- offscreen? ( opengl )"
-
-RDEPEND="
- >=sys-libs/ncurses-5.4-r5:0=
- >=sys-libs/readline-4.3-r5:0=
- imagemagick? ( media-gfx/imagemagick[png] )
- opengl? ( >=media-libs/mesa-8 )
- offscreen? ( media-libs/mesa[osmesa] )
- svg? ( app-text/dvisvgm )
- sigsegv? ( dev-libs/libsigsegv )
- boehm-gc? ( >=dev-libs/boehm-gc-7.0[cxx,threads] )
- fftw? ( >=sci-libs/fftw-3.0.1 )
- gsl? ( sci-libs/gsl )
- python? ( ${PYTHON_DEPS} )
- X? (
- ${PYTHON_DEPS}
- x11-misc/xdg-utils
- dev-python/pillow[tk,${PYTHON_USEDEP}]
- )
- latex? (
- virtual/latex-base
- >=dev-texlive/texlive-latexextra-2013
- )
- emacs? ( virtual/emacs )
- vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
-DEPEND="${RDEPEND}
- doc? (
- dev-lang/perl
- media-gfx/imagemagick[png]
- virtual/texi2dvi
- virtual/latex-base
- )"
-
-TEXMF=/usr/share/texmf-site
-
-pkg_setup() {
- (use python || use X) && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # Fixing sigsegv enabling
- epatch "${FILESDIR}/${P}-configure-ac.patch"
- einfo "Patching configure.ac"
- sed -e "s:Datadir/doc/asymptote:Datadir/doc/${PF}:" \
- -i configure.ac \
- || die "sed configure.ac failed"
-
- # Changing pdf, ps, image viewers to xdg-open
- epatch "${FILESDIR}/${P}-xdg-utils.patch"
-
- # Bug #322473
- epatch "${FILESDIR}/${P}-info.patch"
-
- # Bug #528632 - fix from https://www.archlinux.org/packages/extra/x86_64/asymptote/
- epatch "${FILESDIR}/${P}-ghostscript-9.15.patch"
-
- eautoreconf
-}
-
-src_configure() {
- # for the CPPFLAGS see
- # https://sourceforge.net/forum/forum.php?thread_id=1683277&forum_id=409349
- econf \
- CPPFLAGS=-DHAVE_SYS_TYPES_H \
- CFLAGS="${CXXFLAGS}" \
- --disable-gc-debug \
- $(use_enable boehm-gc gc system) \
- $(use_enable fftw) \
- $(use_enable gsl) \
- $(use_enable opengl gl) \
- $(use_enable offscreen) \
- $(use_with sigsegv)
-}
-
-src_compile() {
- default
-
- cd doc || die
- emake asy.1
- if use doc; then
- # info
- einfo "Making info"
- emake ${PN}.info
- cd FAQ || die
- emake
- cd .. || die
- # pdf
- einfo "Making pdf docs"
- export VARTEXFONTS="${T}"/fonts
- # see bug #260606
- emake -j1 asymptote.pdf
- emake CAD.pdf
- fi
- cd .. || die
-
- if use emacs; then
- einfo "Compiling emacs lisp files"
- elisp-compile base/*.el
- fi
-}
-
-src_install() {
- # the program
- dobin asy
-
- # .asy files
- insinto /usr/share/${PN}
- doins base/*.asy
-
- # documentation
- dodoc BUGS ChangeLog README ReleaseNotes TODO
- doman doc/asy.1
-
- # X GUI
- if use X; then
- python_scriptinto /usr/share/${PN}/GUI
- python_doscript GUI/*.py
- dosym /usr/share/${PN}/GUI/xasy.py /usr/bin/xasy
- doman doc/xasy.1x
- fi
-
- # examples
- if use examples; then
- insinto /usr/share/${PN}/examples
- doins \
- examples/*.asy \
- examples/*.eps \
- doc/*.asy \
- doc/*.csv \
- doc/*.dat \
- doc/extra/*.asy
- use X && doins GUI/*.asy
-
- insinto /usr/share/${PN}/examples/animations
- doins examples/animations/*.asy
- fi
-
- # LaTeX style
- if use latex; then
- cd doc || die
- insinto "${TEXMF}"/tex/latex/${PN}
- doins ${PN}.sty asycolors.sty
- if use examples; then
- insinto /usr/share/${PN}/examples
- doins latexusage.tex
- fi
- cd .. || die
- fi
-
- # asymptote.py
- use python && python_domodule base/${PN}.py
-
- # emacs mode
- if use emacs; then
- elisp-install ${PN} base/*.el base/*.elc
- elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
- fi
-
- # vim syntax
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins base/asy.vim
- insinto /usr/share/vim/vimfiles/ftdetect
- doins "${FILESDIR}"/asy-ftd.vim
- fi
-
- # extra documentation
- if use doc; then
- cd doc || die
- doinfo ${PN}.info*
- cd FAQ || die
- dodoc asy-faq.ascii
- doinfo asy-faq.info
- insinto /usr/share/doc/${PF}/html/FAQ
- doins asy-faq.html/*
- cd .. || die
- insinto /usr/share/doc/${PF}
- doins ${PN}.pdf CAD.pdf
- fi
-}
-
-pkg_postinst() {
- use latex && latex-package_rehash
- use emacs && elisp-site-regen
-
- elog 'Use the variable ASYMPTOTE_PSVIEWER to set the postscript viewer'
- elog 'Use the variable ASYMPTOTE_PDFVIEWER to set the PDF viewer'
-}
-
-pkg_postrm() {
- use latex && latex-package_rehash
- use emacs && elisp-site-regen
-}