summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild9
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild7
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
index ffbdbd5e4ddd..dbbdbd2de31c 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -70,6 +70,13 @@ src_configure() {
filter-flags '-mfunction-return=thunk*' #878849
fi
local CHOST=${CTARGET}
+
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ tc-is-gcc && append-flags -mno-avx
+
strip-unsupported-flags
# Normally mingw64 does not use dynamic linker.
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild
index e9b21a93f78c..5e0b60934d20 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild
@@ -65,6 +65,13 @@ src_configure() {
filter-flags '-mfunction-return=thunk*' #878849
fi
local CHOST=${CTARGET}
+
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ tc-is-gcc && append-flags -mno-avx
+
strip-unsupported-flags
# Normally mingw64 does not use dynamic linker, but at configure time it