summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/gtk-splitter/gtk-splitter-2.2.1-r2.ebuild (renamed from app-arch/gtk-splitter/gtk-splitter-2.2.1-r1.ebuild)22
1 files changed, 9 insertions, 13 deletions
diff --git a/app-arch/gtk-splitter/gtk-splitter-2.2.1-r1.ebuild b/app-arch/gtk-splitter/gtk-splitter-2.2.1-r2.ebuild
index 0ccad4c508c7..288cc392ddae 100644
--- a/app-arch/gtk-splitter/gtk-splitter-2.2.1-r1.ebuild
+++ b/app-arch/gtk-splitter/gtk-splitter-2.2.1-r2.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-
-inherit eutils
+EAPI=7
DESCRIPTION="Split files into smaller pieces and combine them back together"
HOMEPAGE="http://gtk-splitter.sourceforge.net"
@@ -14,18 +12,16 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="crypt"
-RDEPEND="x11-libs/gtk+:2
+RDEPEND="
+ x11-libs/gtk+:2
virtual/libintl:0
crypt? ( >=app-crypt/mhash-0.8:0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-DEPEND="${RDEPEND}
- virtual/pkgconfig:*"
-
-src_prepare() {
- epatch "${FILESDIR}/"${P}-r1-desktop-QA-fixes.patch
-}
+PATCHES=( "${FILESDIR}"/${P}-r1-desktop-QA-fixes.patch )
-src_compile() {
+src_configure() {
default
if ! use crypt ; then
@@ -35,5 +31,5 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}" install
}