summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/jargon/jargon-4.4.7-r2.ebuild')
-rw-r--r--app-doc/jargon/jargon-4.4.7-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-doc/jargon/jargon-4.4.7-r2.ebuild b/app-doc/jargon/jargon-4.4.7-r2.ebuild
new file mode 100644
index 000000000000..5a209b20012a
--- /dev/null
+++ b/app-doc/jargon/jargon-4.4.7-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A compendium of hacker slang illuminating many aspects of hackish tradition"
+HOMEPAGE="http://www.catb.org/jargon/"
+SRC_URI="http://www.catb.org/jargon/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+src_prepare() {
+ default
+ find . -name .xvpics | xargs rm -rf
+ assert
+ cd html || die
+ sed -i -e 's#\.\./\.\.#..#' */* \
+ || die "sed failed"
+}
+
+src_install() {
+ docinto html
+ dodoc -r html/.
+}