summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/e3')
-rw-r--r--app-editors/e3/Manifest1
-rw-r--r--app-editors/e3/e3-2.8.ebuild38
-rw-r--r--app-editors/e3/metadata.xml16
3 files changed, 55 insertions, 0 deletions
diff --git a/app-editors/e3/Manifest b/app-editors/e3/Manifest
new file mode 100644
index 000000000000..5c6c02eae1d8
--- /dev/null
+++ b/app-editors/e3/Manifest
@@ -0,0 +1 @@
+DIST e3-2.8.tgz 119939 SHA256 035737d0cc82b287386fdff8682b2c23ef620d7ef97dff7a1b1fe1777e4c4fb7 SHA512 f3443ac558203b6921458761174ebc060936ae9f8a834670044152b9af52e0919075ac8110ba47b4b6f4e8261afa917e9fe49492b8d40d38d69987353ddd5189 WHIRLPOOL 9531a30229fe78bb2f55621d085d561923cae4b7db6c91f46320c81516936389f765fa0ef8bc65c19fefae40a60e50b5541f1e751a03aabf56d6b57dbf4cb165
diff --git a/app-editors/e3/e3-2.8.ebuild b/app-editors/e3/e3-2.8.ebuild
new file mode 100644
index 000000000000..b7ed30080e75
--- /dev/null
+++ b/app-editors/e3/e3-2.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Very tiny editor in ASM with emacs, pico, wordstar, and vi keybindings"
+HOMEPAGE="http://sites.google.com/site/e3editor/"
+SRC_URI="http://sites.google.com/site/e3editor/Home/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+RESTRICT="strip"
+
+DEPEND=">=dev-lang/nasm-2.09.04"
+RDEPEND=""
+
+src_prepare() {
+ sed -i 's/-D$(EXMODE)//' Makefile || die
+}
+
+src_compile() {
+ emake -- $(usex amd64 64 32)
+}
+
+src_install() {
+ dobin e3
+ dosym e3 /usr/bin/e3em
+ dosym e3 /usr/bin/e3ne
+ dosym e3 /usr/bin/e3pi
+ dosym e3 /usr/bin/e3vi
+ dosym e3 /usr/bin/e3ws
+
+ newman e3.man e3.1
+ dohtml e3.html
+ dodoc ChangeLog README README_OLD
+}
diff --git a/app-editors/e3/metadata.xml b/app-editors/e3/metadata.xml
new file mode 100644
index 000000000000..ddec4ff80d90
--- /dev/null
+++ b/app-editors/e3/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ e3 is a full-screen, user-friendly text editor with an interface similar to
+ that of either WordStar, Emacs, Pico, Nedit, or vi. It's heavily optimized
+ for size and independent of libc or any other libraries, making it useful
+ for mini-Linux distributions and rescue disks. The assembler version
+ supports Linux, FreeBSD, OpenBSD, NetBSD, Win9x, QNX, Atheos, BeOS, ELKS,
+ and DOS. There is also a separately distributed version written in C which
+ supports some other Unix versions and CygWin. It is also possible to use
+ regular expressions by using child processes like sed. e3 has a built in
+ arithmetic calculator.
+</longdescription>
+</pkgmetadata>