summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/ctemplate/ctemplate-2.2.ebuild')
-rw-r--r--dev-cpp/ctemplate/ctemplate-2.2.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/dev-cpp/ctemplate/ctemplate-2.2.ebuild b/dev-cpp/ctemplate/ctemplate-2.2.ebuild
deleted file mode 100644
index d41b4590318b..000000000000
--- a/dev-cpp/ctemplate/ctemplate-2.2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit elisp-common python
-
-DESCRIPTION="A simple but powerful template language for C++"
-HOMEPAGE="https://github.com/olafvdspek/ctemplate"
-SRC_URI="https://ctemplate.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm ppc x86 ~amd64-linux ~x86-linux"
-IUSE="doc emacs vim-syntax static-libs test"
-
-DEPEND="test? ( =dev-lang/python-2* )"
-RDEPEND="vim-syntax? ( >=app-editors/vim-core-7 )
- emacs? ( virtual/emacs )"
-
-SITEFILE="70ctemplate-gentoo.el"
-
-pkg_setup() {
- if use test ; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_configure() {
- econf \
- --enable-shared \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- default
-
- if use emacs ; then
- elisp-compile contrib/tpl-mode.el || die "elisp-compile failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- # Installs just every piece
- rm -rf "${ED}/usr/share/doc"
-
- dodoc AUTHORS ChangeLog NEWS README
- use doc && dohtml doc/*
-
- if use vim-syntax ; then
- cd "${S}/contrib"
- sh highlighting.vim || die "unpacking vim scripts failed"
- insinto /usr/share/vim/vimfiles
- doins -r .vim/*
- fi
-
- if use emacs ; then
- cd "${S}/contrib"
- elisp-install ${PN} tpl-mode.el tpl-mode.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- find "${ED}" -name '*.la' -exec rm -f {} +
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}