summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jsr250/jsr250-1.0-r1.ebuild')
-rw-r--r--dev-java/jsr250/jsr250-1.0-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-java/jsr250/jsr250-1.0-r1.ebuild b/dev-java/jsr250/jsr250-1.0-r1.ebuild
new file mode 100644
index 000000000000..115c04182e79
--- /dev/null
+++ b/dev-java/jsr250/jsr250-1.0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="JSR 250 Common Annotations"
+HOMEPAGE="https://jcp.org/en/jsr/detail?id=250"
+SRC_URI="http://download.java.net/maven/2/javax/annotation/${PN}-api/${PV}/${PN}-api-${PV}-sources.jar"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip"