summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/jbuilder/jbuilder-1.0_beta12.ebuild')
-rw-r--r--dev-ml/jbuilder/jbuilder-1.0_beta12.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/jbuilder/jbuilder-1.0_beta12.ebuild b/dev-ml/jbuilder/jbuilder-1.0_beta12.ebuild
new file mode 100644
index 000000000000..73b64735ff87
--- /dev/null
+++ b/dev-ml/jbuilder/jbuilder-1.0_beta12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit opam
+
+MY_PV="${PV/_/+}"
+MY_P="${PN}-${PV/_/-}"
+
+DESCRIPTION="A composable build system for OCaml"
+HOMEPAGE="https://github.com/janestreet/jbuilder"
+SRC_URI="https://github.com/janestreet/jbuilder/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? ( dev-ml/menhir )
+"
+OPAMSWITCH="system"
+
+S="${WORKDIR}/${MY_P}"
+OPAMROOT="${D}"
+
+src_prepare() {
+ # Disable Werror like behavior, doesnt build with ocaml 4.05 otherwise
+ sed -i -e 's/--dev//' Makefile || die
+}