summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_deriving/ppx_deriving-4.2-r1.ebuild')
-rw-r--r--dev-ml/ppx_deriving/ppx_deriving-4.2-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-ml/ppx_deriving/ppx_deriving-4.2-r1.ebuild b/dev-ml/ppx_deriving/ppx_deriving-4.2-r1.ebuild
new file mode 100644
index 000000000000..928e7ba1e3cd
--- /dev/null
+++ b/dev-ml/ppx_deriving/ppx_deriving-4.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit findlib eutils opam
+
+DESCRIPTION="Type-driven code generation for OCaml"
+HOMEPAGE="https://github.com/ocaml-ppx/ppx_deriving"
+SRC_URI="https://github.com/ocaml-ppx/ppx_deriving/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt test"
+
+DEPEND="
+ dev-ml/ppx_tools:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_derivers:=
+ dev-ml/result:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+ test? ( dev-ml/ounit )"
+
+src_compile() {
+ cp pkg/META.in pkg/META || die
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ || die
+ use doc && emake doc
+}
+
+src_test() {
+ ocamlbuild -j 0 -use-ocamlfind -classic-display \
+ src_test/test_ppx_deriving.byte -- || die
+ if use ocamlopt; then
+ ocamlbuild -j 0 -use-ocamlfind -classic-display \
+ src_test/test_ppx_deriving.native -- || die
+ fi
+}
+
+src_install() {
+ opam_src_install
+ mv "${ED}/usr/lib/ppx_deriving/ppx_deriving" "${D}/$(ocamlc -where)/ppx_deriving/" || die
+
+ use doc && dohtml api.docdir/*
+}