summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/seq/seq-0.1.ebuild')
-rw-r--r--dev-ml/seq/seq-0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/seq/seq-0.1.ebuild b/dev-ml/seq/seq-0.1.ebuild
new file mode 100644
index 000000000000..7f02fe75de7e
--- /dev/null
+++ b/dev-ml/seq/seq-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Compatibility package for the standard OCaml iterator type"
+HOMEPAGE="https://github.com/c-cube/seq"
+SRC_URI="https://github.com/c-cube/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-ml/ocamlbuild"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:@LIBDIR@:/usr/$(get_libdir)/ocaml:" \
+ Makefile \
+ || die
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)/ocaml
+ default
+}