summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/gnome2-wnck/gnome2-wnck-0.160.0-r2.ebuild')
-rw-r--r--dev-perl/gnome2-wnck/gnome2-wnck-0.160.0-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/gnome2-wnck/gnome2-wnck-0.160.0-r2.ebuild b/dev-perl/gnome2-wnck/gnome2-wnck-0.160.0-r2.ebuild
new file mode 100644
index 000000000000..294a94659e89
--- /dev/null
+++ b/dev-perl/gnome2-wnck/gnome2-wnck-0.160.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_NAME=Gnome2-Wnck
+DIST_AUTHOR=TSCH
+DIST_VERSION=0.16
+
+inherit perl-module virtualx
+
+DESCRIPTION="Perl interface to the Window Navigator Construction Kit"
+HOMEPAGE="http://gtk2-perl.sourceforge.net/ ${HOMEPAGE}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-perl/glib-perl-1.180.0
+ >=dev-perl/Gtk2-1.42.0
+ >=x11-libs/libwnck-2.20:1"
+DEPEND="${RDEPEND}
+ >=dev-perl/ExtUtils-PkgConfig-1.03
+ >=dev-perl/ExtUtils-Depends-0.2"
+
+src_test() {
+ perl_rm_files t/WnckWorkspace.t
+ virtx perl-module_src_test
+}