summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyContracts/PyContracts-1.7.9.ebuild')
-rw-r--r--dev-python/PyContracts/PyContracts-1.7.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/PyContracts/PyContracts-1.7.9.ebuild b/dev-python/PyContracts/PyContracts-1.7.9.ebuild
new file mode 100644
index 000000000000..a0aefee7bf4f
--- /dev/null
+++ b/dev-python/PyContracts/PyContracts-1.7.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Declare constraints on function parameters and return values"
+HOMEPAGE="http://andreacensi.github.com/contracts/ https://pypi.python.org/pypi/PyContracts/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+# Upstream allows tests to fail
+RESTRICT=test
+
+python_test() {
+ nosetests \
+ $(python_is_python3 || echo "--ignore-files=test_py3k_annotations.py") \
+ || die
+}