summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/envoy/envoy-0.0.3.ebuild')
-rw-r--r--dev-python/envoy/envoy-0.0.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/envoy/envoy-0.0.3.ebuild b/dev-python/envoy/envoy-0.0.3.ebuild
new file mode 100644
index 000000000000..0347ba0f991b
--- /dev/null
+++ b/dev-python/envoy/envoy-0.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple API for running external processes"
+HOMEPAGE="https://github.com/kennethreitz/envoy http://pypi.python.org/pypi/envoy"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ # and it fails almost all;https://github.com/kennethreitz/envoy/issues/58
+ "${PYTHON}" test_envoy.py
+}