summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hpack/hpack-3.0.0-r1.ebuild')
-rw-r--r--dev-python/hpack/hpack-3.0.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/hpack/hpack-3.0.0-r1.ebuild b/dev-python/hpack/hpack-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..22154a1a396e
--- /dev/null
+++ b/dev-python/hpack/hpack-3.0.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python HPACK header compression"
+HOMEPAGE="
+ https://python-hyper.org/projects/hpack/en/latest/
+ https://github.com/python-hyper/hpack/
+ https://pypi.org/project/hpack/
+"
+SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# dev-python/pytest-relaxed causes tests to fail
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ !!dev-python/pytest-relaxed[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/hpack-3.0.0-hypothesis-healthcheck.patch
+)
+
+EPYTEST_DESELECT=(
+ # relies on outdated exception strings
+ test/test_table.py::TestHeaderTable::test_get_by_index_out_of_range
+)
+
+EPYTEST_IGNORE=(
+ bench
+)