summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hyperlink/hyperlink-17.1.1.ebuild')
-rw-r--r--dev-python/hyperlink/hyperlink-17.1.1.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/hyperlink/hyperlink-17.1.1.ebuild b/dev-python/hyperlink/hyperlink-17.1.1.ebuild
deleted file mode 100644
index c371206436b3..000000000000
--- a/dev-python/hyperlink/hyperlink-17.1.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6)
-
-inherit distutils-r1
-
-DESCRIPTION="A featureful, correct URL for Python"
-HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.org/project/hyperlink/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
- py.test -v || die
- cd test
-}