summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-config/oslo-config-2.4.0.ebuild')
-rw-r--r--dev-python/oslo-config/oslo-config-2.4.0.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/oslo-config/oslo-config-2.4.0.ebuild b/dev-python/oslo-config/oslo-config-2.4.0.ebuild
deleted file mode 100644
index 17d7d1456985..000000000000
--- a/dev-python/oslo-config/oslo-config-2.4.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
-
-inherit distutils-r1 vcs-snapshot
-
-MY_PN=${PN/-/.}
-
-DESCRIPTION="Oslo Configuration API"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-CDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
- >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/mock-1.2[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- sed -i '/^argparse/d' requirements.txt || die
- use doc && esetup.py build_sphinx
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- rm -rf .testrepository || die "could not remove '.testrepository' under ${EPTYHON}"
-
- testr init || die "testr init failed under ${EPYTHON}"
- testr run || die "testr run failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-}