summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-policy/oslo-policy-0.11.0.ebuild')
-rw-r--r--dev-python/oslo-policy/oslo-policy-0.11.0.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/oslo-policy/oslo-policy-0.11.0.ebuild b/dev-python/oslo-policy/oslo-policy-0.11.0.ebuild
deleted file mode 100644
index b419486a6499..000000000000
--- a/dev-python/oslo-policy/oslo-policy-0.11.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4)
-
-inherit distutils-r1
-
-DESCRIPTION="The Oslo Policy library provides support for RBAC policy enforcement across all OpenStack services."
-HOMEPAGE="https://pypi.python.org/pypi/oslo.policy"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.policy/oslo.policy-${PV}.tar.gz"
-S="${WORKDIR}/oslo.policy-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.3.0[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/oslo-config-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-serialization-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-"
-
-# This time half the doc files are missing; Do you want them?
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests tests/ || die "test failed under ${EPYTHON}"
-}