summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-poppler-qt4/python-poppler-qt4-0.24.0.ebuild')
-rw-r--r--dev-python/python-poppler-qt4/python-poppler-qt4-0.24.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-poppler-qt4/python-poppler-qt4-0.24.0.ebuild b/dev-python/python-poppler-qt4/python-poppler-qt4-0.24.0.ebuild
new file mode 100644
index 000000000000..cab4b8413c80
--- /dev/null
+++ b/dev-python/python-poppler-qt4/python-poppler-qt4-0.24.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python binding for libpoppler-qt4"
+HOMEPAGE="https://github.com/wbsoft/python-poppler-qt4"
+SRC_URI="https://github.com/wbsoft/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/poppler:=[qt4]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/sip:=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"