summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rackspace-monitoring/rackspace-monitoring-0.8.0.ebuild')
-rw-r--r--dev-python/rackspace-monitoring/rackspace-monitoring-0.8.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/rackspace-monitoring/rackspace-monitoring-0.8.0.ebuild b/dev-python/rackspace-monitoring/rackspace-monitoring-0.8.0.ebuild
new file mode 100644
index 000000000000..08341a863dab
--- /dev/null
+++ b/dev-python/rackspace-monitoring/rackspace-monitoring-0.8.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Client library for Rackspace Cloud Monitoring"
+HOMEPAGE="https://github.com/racker/rackspace-monitoring"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # resrticted for bug 636106
+
+TEST_DEPENDS="dev-python/pep8[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/libcloud-0.17.0[${PYTHON_USEDEP}]
+ <dev-python/libcloud-2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${TEST_DEPENDS}
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ ${EPYTHON} setup.py test || die
+}