summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/multi_xml/multi_xml-0.6.0.ebuild')
-rw-r--r--dev-ruby/multi_xml/multi_xml-0.6.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-ruby/multi_xml/multi_xml-0.6.0.ebuild b/dev-ruby/multi_xml/multi_xml-0.6.0.ebuild
deleted file mode 100644
index f99474a2df51..000000000000
--- a/dev-ruby/multi_xml/multi_xml-0.6.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_TASK_DOC="yard"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A generic swappable back-end for XML parsing"
-HOMEPAGE="http://rdoc.info/gems/multi_xml"
-SRC_URI="https://github.com/sferik/multi_xml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-SLOT="0"
-IUSE=""
-
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-ruby_add_bdepend "test? ( dev-ruby/ox )"
-
-all_ruby_prepare() {
- sed -i -e '/simplecov/,/^end/ s:^:#:' spec/helper.rb || die
- sed -i -e '/bundler/I s:^:#:' -e '/yardstick/,/end/ s:^:#:' Rakefile || die
-}
-
-each_ruby_test() {
- CI=true each_fakegem_test
-}