summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/oauth/oauth-0.5.3.ebuild')
-rw-r--r--dev-ruby/oauth/oauth-0.5.3.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-ruby/oauth/oauth-0.5.3.ebuild b/dev-ruby/oauth/oauth-0.5.3.ebuild
deleted file mode 100644
index d24757d80339..000000000000
--- a/dev-ruby/oauth/oauth-0.5.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRADOC="HISTORY README.rdoc TODO"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A RubyGem for implementing both OAuth clients and servers"
-HOMEPAGE="https://github.com/oauth-xx/oauth-ruby"
-SRC_URI="https://github.com/oauth-xx/oauth-ruby/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="${PN}-ruby-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-macos"
-IUSE=""
-
-ruby_add_bdepend "test? (
- dev-ruby/test-unit:2
- dev-ruby/mocha:1.0
- dev-ruby/webmock
- dev-ruby/rack
- dev-ruby/actionpack:4.2
-)"
-
-all_ruby_prepare() {
- # Require a compatible version of mocha
- sed -i -e '1igem "mocha", "~> 1.0"; gem "actionpack", "~>4.2.0"' \
- -e '2i gem "test-unit"; require "test/unit"' \
- -e '/\(byebug\|minitest_helpers\|simplecov\)/I s:^:#:' test/test_helper.rb || die
-}