summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pluggaloid/pluggaloid-1.5.0.ebuild')
-rw-r--r--dev-ruby/pluggaloid/pluggaloid-1.5.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/pluggaloid/pluggaloid-1.5.0.ebuild b/dev-ruby/pluggaloid/pluggaloid-1.5.0.ebuild
new file mode 100644
index 000000000000..493b5e874163
--- /dev/null
+++ b/dev-ruby/pluggaloid/pluggaloid-1.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+DESCRIPTION="Pluggaloid is extensible plugin system for mikutter"
+HOMEPAGE="https://rubygems.org/gems/pluggaloid/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/delayer-1.1.0:1
+ dev-ruby/instance_storage:0
+"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile test/*_test.rb || die
+}