summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rex-zip/rex-zip-0.1.3.ebuild')
-rw-r--r--dev-ruby/rex-zip/rex-zip-0.1.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/rex-zip/rex-zip-0.1.3.ebuild b/dev-ruby/rex-zip/rex-zip-0.1.3.ebuild
new file mode 100644
index 000000000000..0fec4e5d74ee
--- /dev/null
+++ b/dev-ruby/rex-zip/rex-zip-0.1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+# Upstream has specs but they are not included in the gem or tagged upstream
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby Exploitation(Rex) library for working with zip and related files"
+HOMEPAGE="https://rubygems.org/gems/rex-zip"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rex-text"