summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/corsix-th/corsix-th-0.62.ebuild4
-rw-r--r--games-simulation/corsix-th/files/corsix-th-0.62-gcc-10.patch10
2 files changed, 13 insertions, 1 deletions
diff --git a/games-simulation/corsix-th/corsix-th-0.62.ebuild b/games-simulation/corsix-th/corsix-th-0.62.ebuild
index dd775153d21a..b7772ebb3381 100644
--- a/games-simulation/corsix-th/corsix-th-0.62.ebuild
+++ b/games-simulation/corsix-th/corsix-th-0.62.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -34,6 +34,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_PN}-${MY_PV}"
+PATCHES=("${FILESDIR}"/${P}-gcc-10.patch)
+
src_configure() {
local mycmakeargs=(
-DWITH_AUDIO="$(usex sound)"
diff --git a/games-simulation/corsix-th/files/corsix-th-0.62-gcc-10.patch b/games-simulation/corsix-th/files/corsix-th-0.62-gcc-10.patch
new file mode 100644
index 000000000000..ff820f44946b
--- /dev/null
+++ b/games-simulation/corsix-th/files/corsix-th-0.62-gcc-10.patch
@@ -0,0 +1,10 @@
+--- a/CorsixTH/Src/th_lua_map.cpp
++++ b/CorsixTH/Src/th_lua_map.cpp
+@@ -26,6 +26,7 @@ SOFTWARE.
+ #include <cstring>
+ #include <string>
+ #include <exception>
++#include <stdexcept> /* std::out_of_range */
+
+ static const int player_max = 4;
+