summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxde-base/lxpolkit/lxpolkit-0.1.0-r1.ebuild')
-rw-r--r--lxde-base/lxpolkit/lxpolkit-0.1.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/lxde-base/lxpolkit/lxpolkit-0.1.0-r1.ebuild b/lxde-base/lxpolkit/lxpolkit-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..181102977e3b
--- /dev/null
+++ b/lxde-base/lxpolkit/lxpolkit-0.1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="A simple PolicyKit authentication agent"
+HOMEPAGE="http://lxde.git.sourceforge.net/git/gitweb.cgi?p=lxde/lxpolkit;a=summary http://blog.lxde.org/?p=674"
+SRC_URI="mirror://sourceforge/project/lxde/LXPolkit/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=sys-auth/polkit-0.102
+ x11-libs/gtk+:3
+ !gnome-extra/polkit-gnome"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ local f=data/lxpolkit.desktop.in.in
+ sed -i -e '/^NotShowIn/s:=.*:=KDE;:' ${f} || die
+ echo 'AutostartCondition=GNOME3 if-session gnome-fallback' >> ${f}
+}
+
+src_configure() { econf --enable-gtk3; }