summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pavucontrol-qt/pavucontrol-qt-0.14.1.ebuild')
-rw-r--r--media-sound/pavucontrol-qt/pavucontrol-qt-0.14.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/pavucontrol-qt/pavucontrol-qt-0.14.1.ebuild b/media-sound/pavucontrol-qt/pavucontrol-qt-0.14.1.ebuild
new file mode 100644
index 000000000000..24871a2f6a28
--- /dev/null
+++ b/media-sound/pavucontrol-qt/pavucontrol-qt-0.14.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="A Pulseaudio mixer in Qt (port of pavucontrol)"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.6.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtwidgets:5
+ media-sound/pulseaudio[glib]
+"
+RDEPEND="${DEPEND}"