summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/super_demux')
-rw-r--r--media-video/super_demux/super_demux-0.3-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-video/super_demux/super_demux-0.3-r1.ebuild b/media-video/super_demux/super_demux-0.3-r1.ebuild
new file mode 100644
index 000000000000..5e64d973faf2
--- /dev/null
+++ b/media-video/super_demux/super_demux-0.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="DVB transport stream TS to ES demultiplexer"
+HOMEPAGE="http://panteltje.com/panteltje/dvd/"
+SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}/${P}.diff" )
+
+src_compile() {
+ append-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin super_demux
+ dodoc CHANGES README
+}