summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/trojan/trojan-1.12.3.ebuild')
-rw-r--r--net-proxy/trojan/trojan-1.12.3.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/net-proxy/trojan/trojan-1.12.3.ebuild b/net-proxy/trojan/trojan-1.12.3.ebuild
index e394deff72a0..012870955efa 100644
--- a/net-proxy/trojan/trojan-1.12.3.ebuild
+++ b/net-proxy/trojan/trojan-1.12.3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{3_5,3_6,3_7} )
-inherit cmake-utils python-any-r1 systemd
+inherit cmake python-any-r1 systemd
DESCRIPTION="An unidentifiable mechanism that helps you bypass GFW"
HOMEPAGE="https://github.com/trojan-gfw/${PN}"
@@ -32,16 +32,15 @@ src_configure() {
-DENABLE_MYSQL=$(usex mysql)
-DSYSTEMD_SERVICE=ON
-DSYSTEMD_SERVICE_PATH=$(systemd_get_systemunitdir)
- -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newinitd "${FILESDIR}/trojan.initd" trojan
}
src_test() {
- cmake-utils_src_test -j1
+ cmake_src_test -j1
}