summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/reduce/files/3.14.080821-CFLAGS.patch')
-rw-r--r--sci-chemistry/reduce/files/3.14.080821-CFLAGS.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-chemistry/reduce/files/3.14.080821-CFLAGS.patch b/sci-chemistry/reduce/files/3.14.080821-CFLAGS.patch
new file mode 100644
index 000000000000..8294c8ca385d
--- /dev/null
+++ b/sci-chemistry/reduce/files/3.14.080821-CFLAGS.patch
@@ -0,0 +1,22 @@
+diff --git a/reduce_src/Makefile b/reduce_src/Makefile
+index 598e367..067ace4 100644
+--- a/reduce_src/Makefile
++++ b/reduce_src/Makefile
+@@ -12,7 +12,7 @@ PROG_FLGS = -DAROMATICS_ACCEPT_HBONDS \
+ # -DDEBUGMOVABLENODE -DDEBUGDOTCOUNTS
+ # -DMINPREDEFINED -DMAXPREDEFINED\
+
+-CFLAGS = $(OPT) $(DEBUG) $(PROG_FLGS) $(DICT_LOC) $(DICT_LOCOLD)\
++CXXFLAGS = $(OPT) $(DEBUG) $(PROG_FLGS) $(DICT_LOC) $(DICT_LOCOLD)\
+ -I$(PDBHOME) -I$(TOOLHOME)
+ # -Wall
+
+@@ -26,7 +26,7 @@ OBJLIST = GraphToHoldScores.o reduce.o CTab.o ElementInfo.o StdResH.o ResBlk.o A
+ CXX = g++
+
+ .cpp.o:
+- $(CXX) -c $*.cpp $(CFLAGS)
++ $(CXX) -c $*.cpp $(CXXFLAGS)
+
+ OPT = -O3
+ DEBUG = $(CXXDEBUGFLAGS)