summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/liblas/files/liblas-1.8.0_remove-std-c++98.patch')
-rw-r--r--sci-geosciences/liblas/files/liblas-1.8.0_remove-std-c++98.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-geosciences/liblas/files/liblas-1.8.0_remove-std-c++98.patch b/sci-geosciences/liblas/files/liblas-1.8.0_remove-std-c++98.patch
new file mode 100644
index 000000000000..dc230dad0777
--- /dev/null
+++ b/sci-geosciences/liblas/files/liblas-1.8.0_remove-std-c++98.patch
@@ -0,0 +1,30 @@
+--- libLAS-1.8.0/CMakeLists.txt
++++ libLAS-1.8.0/CMakeLists.txt
+@@ -140,27 +140,6 @@
+
+ set(CMAKE_INCLUDE_PATH c:/osgeo4w64/include;$ENV{CMAKE_INCLUDE_PATH})
+ set(CMAKE_LIBRARY_PATH c:/osgeo4w64/lib;$ENV{CMAKE_LIBRARY_PATH})
+-else()
+-
+- # Recommended C++ compilation flags
+- # -Weffc++
+- #
+- # Remove -pedandic which causes errors from boost (comma at end of
+- # enum) 2012-09-05. Remove -Wcast-qual -Wfloat-equal
+- # -Wredundant-decls to suppress the multitude of warning messages.
+- set(LIBLAS_COMMON_CXX_FLAGS
+- " -Wextra -Wall -Wno-unused-parameter -Wno-unused-variable -Wpointer-arith -Wcast-align -Wcast-qual -Wfloat-equal -Wredundant-decls -Wno-long-long")
+-
+- if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
+-
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${LIBLAS_COMMON_CXX_FLAGS}")
+- if (CMAKE_COMPILER_IS_GNUCXX)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98 -ansi")
+- endif()
+-
+- elseif("${CMAKE_CXX_COMPILER_ID}" MATCHES "Clang" OR "${CMAKE_CXX_COMPILER}" MATCHES "clang")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${LIBLAS_COMMON_CXX_FLAGS}")
+- endif()
+ endif(WIN32)
+
+ if (APPLE)