summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/files/sbat.csv3
-rw-r--r--sys-boot/grub/grub-2.12-r2.ebuild (renamed from sys-boot/grub/grub-2.12-r1.ebuild)4
-rw-r--r--sys-boot/grub/grub-9999.ebuild4
3 files changed, 11 insertions, 0 deletions
diff --git a/sys-boot/grub/files/sbat.csv b/sys-boot/grub/files/sbat.csv
new file mode 100644
index 000000000000..2b87b532556c
--- /dev/null
+++ b/sys-boot/grub/files/sbat.csv
@@ -0,0 +1,3 @@
+sbat,1,SBAT Version,sbat,1,https://github.com/rhboot/shim/blob/main/SBAT.md
+grub,3,Free Software Foundation,grub,%PV%,https//www.gnu.org/software/grub/
+grub.gentoo,1,Gentoo,grub,%PV%,https://bugs.gentoo.org/
diff --git a/sys-boot/grub/grub-2.12-r1.ebuild b/sys-boot/grub/grub-2.12-r2.ebuild
index c6cb75fc4b02..e156b1b4754a 100644
--- a/sys-boot/grub/grub-2.12-r1.ebuild
+++ b/sys-boot/grub/grub-2.12-r2.ebuild
@@ -315,6 +315,10 @@ src_install() {
# https://bugs.gentoo.org/231935
dostrip -x /usr/lib/grub
+ sed -e "s/%PV%/${PV}/" "${FILESDIR}/sbat.csv" > "${T}/sbat.csv" || die
+ insinto /usr/share/grub
+ doins "${T}/sbat.csv"
+
if use elibc_musl; then
# https://bugs.gentoo.org/900348
QA_CONFIG_IMPL_DECL_SKIP=( re_{compile_pattern,match,search,set_syntax} )
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 0ba8261571a5..44bb51e767ee 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -311,6 +311,10 @@ src_install() {
# https://bugs.gentoo.org/231935
dostrip -x /usr/lib/grub
+ sed -e "s/%PV%/${PV}/" "${FILESDIR}/sbat.csv" > "${T}/sbat.csv" || die
+ insinto /usr/share/grub
+ doins "${T}/sbat.csv"
+
if use elibc_musl; then
# https://bugs.gentoo.org/900348
QA_CONFIG_IMPL_DECL_SKIP=( re_{compile_pattern,match,search,set_syntax} )