summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fabric/opensm/opensm-3.3.15.ebuild')
-rw-r--r--sys-fabric/opensm/opensm-3.3.15.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-fabric/opensm/opensm-3.3.15.ebuild b/sys-fabric/opensm/opensm-3.3.15.ebuild
new file mode 100644
index 000000000000..b9b7fbeca50c
--- /dev/null
+++ b/sys-fabric/opensm/opensm-3.3.15.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+OFED_VER="3.5"
+OFED_RC="1"
+OFED_RC_VER="2"
+OFED_SUFFIX="1"
+
+inherit openib
+
+DESCRIPTION="OpenSM - InfiniBand Subnet Manager and Administration for OpenIB"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+DEPEND="
+ sys-fabric/libibmad:${SLOT}
+ sys-fabric/libibumad:${SLOT}"
+RDEPEND="$DEPEND
+ net-misc/iputils"
+block_other_ofed_versions
+
+src_configure() {
+ econf \
+ --enable-perf-mgr \
+ --enable-default-event-plugin \
+ --with-osmv="openib"
+}
+
+src_install() {
+ default
+ newconfd "${S}/scripts/opensm.sysconfig" opensm
+ newinitd "${FILESDIR}/opensm.init.d" opensm
+ insinto /etc/logrotate.d
+ newins "${S}/scripts/opensm.logrotate" opensm
+ # we dont nee this int script
+ rm "${ED}/etc/init.d/opensmd" || die "Dropping of upstream initscript failed"
+}
+
+pkg_postinst() {
+ einfo "To automatically configure the infiniband subnet manager on boot,"
+ einfo "edit /etc/opensm.conf and add opensm to your start-up scripts:"
+ einfo "\`rc-update add opensm default\`"
+}