summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/bbswitch/bbswitch-0.8-r2.ebuild54
-rw-r--r--sys-power/bbswitch/bbswitch-9999.ebuild6
-rw-r--r--sys-power/bbswitch/metadata.xml4
3 files changed, 61 insertions, 3 deletions
diff --git a/sys-power/bbswitch/bbswitch-0.8-r2.ebuild b/sys-power/bbswitch/bbswitch-0.8-r2.ebuild
new file mode 100644
index 000000000000..ad44354463cd
--- /dev/null
+++ b/sys-power/bbswitch/bbswitch-0.8-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Bumblebee-Project/${PN}.git"
+ EGIT_BRANCH="develop"
+else
+ PATCHES=( "${FILESDIR}/${PN}-0.8-kernel-4.12.patch" )
+ SRC_URI="https://github.com/Bumblebee-Project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Toggle discrete NVIDIA Optimus graphics card"
+HOMEPAGE="https://github.com/Bumblebee-Project/bbswitch"
+
+SLOT="0"
+LICENSE="GPL-3+"
+IUSE=""
+
+DEPEND="
+ virtual/linux-sources
+ sys-kernel/linux-headers
+"
+RDEPEND=""
+
+MODULE_NAMES="bbswitch(acpi)"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ BUILD_TARGETS="default"
+ BUILD_PARAMS="KVERSION=${KV_FULL}"
+}
+
+src_prepare() {
+ # Fix build failure, bug #513542
+ sed "s%^KDIR :=.*%KDIR := ${KERNEL_DIR}%g" -i Makefile || die
+
+ default
+}
+
+src_install() {
+ einstalldocs
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/bbswitch.modprobe bbswitch.conf
+
+ linux-mod_src_install
+}
diff --git a/sys-power/bbswitch/bbswitch-9999.ebuild b/sys-power/bbswitch/bbswitch-9999.ebuild
index bb29cb2fd85b..ad44354463cd 100644
--- a/sys-power/bbswitch/bbswitch-9999.ebuild
+++ b/sys-power/bbswitch/bbswitch-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit linux-mod
@@ -39,7 +39,7 @@ pkg_setup() {
src_prepare() {
# Fix build failure, bug #513542
- sed -i 's/^KDIR.*$/KDIR\ \:= \/usr\/src\/linux/g' Makefile || die
+ sed "s%^KDIR :=.*%KDIR := ${KERNEL_DIR}%g" -i Makefile || die
default
}
diff --git a/sys-power/bbswitch/metadata.xml b/sys-power/bbswitch/metadata.xml
index 437e2daa175e..4c90e0a75de3 100644
--- a/sys-power/bbswitch/metadata.xml
+++ b/sys-power/bbswitch/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
+ <email>slashbeast@gentoo.org</email>
+ <name>Piotr Karbowski</name>
+ </maintainer>
+ <maintainer type="person">
<email>NP-Hardass@gentoo.org</email>
<name>NP-Hardass</name>
</maintainer>