summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlbert Diserholt <albert@diserholt.com>2020-03-01 17:05:52 +0100
committerAlbert Diserholt <albert@diserholt.com>2020-03-01 17:05:52 +0100
commitad34cfde805aec8a53bf26a9d9cb614a1b166a58 (patch)
treeb6a7546f20ec2e6aff22a36a4db133049df31aa2
parentgames-engines/love-11.2 & games-engines/love-11.3 (diff)
downloadDrauthius-ad34cfde.tar.gz
Drauthius-ad34cfde.tar.bz2
Drauthius-ad34cfde.zip
dev-games/godot-3.2
Signed-off-by: Albert Diserholt <albert@diserholt.com>
-rw-r--r--dev-games/godot/Manifest2
-rw-r--r--dev-games/godot/godot-3.2.ebuild160
2 files changed, 162 insertions, 0 deletions
diff --git a/dev-games/godot/Manifest b/dev-games/godot/Manifest
index 96e491a..ef89ee4 100644
--- a/dev-games/godot/Manifest
+++ b/dev-games/godot/Manifest
@@ -1,3 +1,5 @@
DIST 3.1.1-stable.zip 25427059 BLAKE2B 85c4df448f5af7f96a3f5a3ba8e23e7764f83e1a43b21807ccf3ba66356aa3ec1dc56242dcf7d0c7d1d9efcba56b7eab8cfc32e314d1f35978bd34d2c300f65e SHA512 509b144be7416174a487548b5708367f7ce743b0268a710d0dc9a9fb095eb368a218bf5cd591f38f90bb9a96fa24acab442c503f4ea91b485274503e381569cd
+DIST 3.2-stable.zip 27425566 BLAKE2B 844e14e7ca850bede631675c831211e23f046f3205cb3ac46c24e880aa6edd55fb5537e160bd4af96c71ab816f68d47c58a123e80236b722ac0e321915aa9989 SHA512 2f63156a7d4f204052b59745b3d8717f440f2f5759adda414296b6c784e79a162f422e8c38a7d624c1f7be17175291e4602dd1416d41b3241ae425a25806beab
EBUILD godot-3.1.1.ebuild 3794 BLAKE2B 110ee31e86a3a4202cffac3be24dc3037430fd2bc9e4b1c9a6d67c730f5d5250c4df9f539dabb38465a2196877280696cebaf638fdb1031050ab97bf45be9f12 SHA512 af13c9c329ac5b7d33272c0bccfe0e02663d98dd09d4e3342a58c7a083d9b7df0ab5c38fd51ac5bfa5cdbe51f14865f59a8cab20010acec98b5a7ad9825d60b9
+EBUILD godot-3.2.ebuild 3628 BLAKE2B 87946423e0c5fdc6f390fb39a9d9fa08f9b52ef293d0f21b6bf967e465c95b5aeaacd5f6cec421d185d54c348fa19ab3a0468cda49bb8c4a2e7bc6952ee056b8 SHA512 e6ec086937b04bbea2f5e804843f02972d043a67047d605cf723bfa26e98a1eb2e1ae5e074eb2ab462b01eb386bc2a22f1b7d7081733ad6aefe83a6a38dbe1dc
EBUILD godot-9999.ebuild 3794 BLAKE2B 110ee31e86a3a4202cffac3be24dc3037430fd2bc9e4b1c9a6d67c730f5d5250c4df9f539dabb38465a2196877280696cebaf638fdb1031050ab97bf45be9f12 SHA512 af13c9c329ac5b7d33272c0bccfe0e02663d98dd09d4e3342a58c7a083d9b7df0ab5c38fd51ac5bfa5cdbe51f14865f59a8cab20010acec98b5a7ad9825d60b9
diff --git a/dev-games/godot/godot-3.2.ebuild b/dev-games/godot/godot-3.2.ebuild
new file mode 100644
index 0000000..35d16df
--- /dev/null
+++ b/dev-games/godot/godot-3.2.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2020 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{6..8} )
+
+inherit eutils python-any-r1 scons-utils flag-o-matic llvm desktop
+
+DESCRIPTION="Multi-platform 2D and 3D game engine"
+HOMEPAGE="http://godotengine.org"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/godotengine/${PN}"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://github.com/godotengine/${PN}/archive/${PV}-stable.zip"
+ S="${WORKDIR}/${P}-stable"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+IUSE="
+ debug
+ +enet
+ +freetype
+ llvm
+ lto
+ +mbedtls
+ +opus
+ pulseaudio
+ theora
+ +udev
+ +vorbis
+ +webp"
+
+DEPEND="
+ >=app-arch/bzip2-1.0.6-r6
+ >=app-arch/lz4-0_p120
+ >=app-arch/xz-utils-5.0.8
+ >=app-arch/zstd-1.4.4
+ >=dev-libs/json-c-0.11-r1
+ dev-libs/libpcre2[pcre32]
+ >=media-libs/alsa-lib-1.0.28
+ >=media-libs/flac-1.3.1-r1
+ >=media-libs/libogg-1.3.1
+ >=media-libs/libsndfile-1.0.25-r1
+ media-libs/libvpx
+ >=media-libs/mesa-10.2.8[gles2]
+ webp? ( media-libs/libwebp )
+ opus? ( media-libs/opus )
+ enet? ( net-libs/enet )
+ >=net-libs/libasyncns-0.8-r3
+ mbedtls? ( net-libs/mbedtls )
+ net-libs/miniupnpc
+ >=sys-apps/attr-2.4.47-r1
+ >=sys-apps/tcp-wrappers-7.6.22-r1
+ >=sys-apps/util-linux-2.25.2-r2
+ !llvm? ( >=sys-devel/gcc-4.6.4:*[cxx] )
+ >=sys-libs/gdbm-1.11
+ >=sys-libs/glibc-2.20-r2
+ >=sys-libs/libcap-2.22-r2
+ >=sys-libs/zlib-1.2.8-r1
+ >=x11-libs/libX11-1.6.2
+ >=x11-libs/libXcursor-1.1.14
+ >=x11-libs/libXinerama-1.1.3
+ freetype? ( >=media-libs/freetype-2.5.3-r1:2 )
+ llvm? ( >=sys-devel/llvm-3.6.0 )
+ >=media-libs/libpng-1.6.16:0=
+ pulseaudio? ( >=media-sound/pulseaudio-5.0-r7 )
+ theora? ( media-libs/libtheora )
+ udev? ( virtual/udev )
+ virtual/glu
+ vorbis? ( >=media-libs/libvorbis-1.3.4 )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ llvm_pkg_setup
+}
+
+src_configure() {
+ if use llvm && ! tc-is-clang; then
+ einfo "Enforcing the use of clang due to USE=llvm ..."
+ CC=${CHOST}-clang
+ CXX=${CHOST}-clang++
+ fi
+
+ strip-unsupported-flags
+
+ MYSCONS=(
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ builtin_enet=$(usex enet)
+ builtin_freetype=no
+ builtin_libogg=no
+ builtin_libpng=no
+ builtin_libtheora=$(usex theora)
+ builtin_libvorbis=$(usex vorbis)
+ builtin_libvpx=no
+ builtin_libwebp=$(usex webp)
+ builtin_mbedtls=$(usex mbedtls)
+ builtin_miniupnpc=no
+ builtin_opus=$(usex opus)
+ builtin_pcre2=no
+ builtin_zlib=no
+ builtin_zstd=no
+ module_enet_enabled=$(usex enet)
+ module_freetype_enabled=$(usex freetype)
+ module_mbedtls_enabled=$(usex mbedtls)
+ module_opus_enabled=$(usex opus)
+ module_theora_enabled=$(usex theora)
+ module_vorbis_enabled=$(usex vorbis)
+ module_webp_enabled=$(usex webp)
+ platform=x11
+ pulseaudio=$(usex pulseaudio)
+ tools=yes
+ progress=false
+ verbose=true
+ udev=$(usex udev)
+ use_llvm=$(usex llvm)
+ use_lld=$(usex llvm)
+ use_lto=$(usex lto)
+ target=$(usex debug debug release_debug)
+ )
+}
+
+src_compile() {
+ escons "${MYSCONS[@]}"
+}
+
+src_install() {
+ newicon icon.svg ${PN}.svg
+ dobin bin/godot.*
+ if [[ "${ARCH}" == "amd64" ]]; then
+ if use llvm; then
+ make_desktop_entry godot.x11.tools.64.llvm Godot
+ with_desktop_entry=1
+ else
+ make_desktop_entry godot.x11.tools.64 Godot
+ with_desktop_entry=1
+ fi
+ fi
+
+ if [[ "${ARCH}" == "x86" ]]; then
+ if use llvm; then
+ make_desktop_entry godot.x11.tools.32.llvm Godot
+ with_desktop_entry=1
+ else
+ make_desktop_entry godot.x11.tools.32 Godot
+ with_desktop_entry=1
+ fi
+ fi
+
+ if ! [[ "${with_desktop_entry}" == "1" ]]; then
+ elog "Couldn't detect running architecture to create a desktop file."
+ fi
+}